summaryrefslogtreecommitdiffstats
path: root/external/meta-python2/recipes-devtools/python/python-pyperf_1.7.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'external/meta-python2/recipes-devtools/python/python-pyperf_1.7.0.bb')
-rw-r--r--external/meta-python2/recipes-devtools/python/python-pyperf_1.7.0.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/external/meta-python2/recipes-devtools/python/python-pyperf_1.7.0.bb b/external/meta-python2/recipes-devtools/python/python-pyperf_1.7.0.bb
new file mode 100644
index 00000000..e722b08d
--- /dev/null
+++ b/external/meta-python2/recipes-devtools/python/python-pyperf_1.7.0.bb
@@ -0,0 +1,34 @@
+SUMMARY = "A toolkit to write, run and analyze benchmarks"
+DESCRIPTION = " \
+The Python pyperf module is a toolkit to write, run and analyze benchmarks. \
+Features: \
+ * Simple API to run reliable benchmarks \
+ * Automatically calibrate a benchmark for a time budget. \
+ * Spawn multiple worker processes. \
+ * Compute the mean and standard deviation. \
+ * Detect if a benchmark result seems unstable. \
+ * JSON format to store benchmark results. \
+ * Support multiple units: seconds, bytes and integer. \
+"
+HOMEPAGE = "https://github.com/vstinner/pyperf"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://COPYING;md5=78bc2e6e87c8c61272937b879e6dc2f8"
+
+SRC_URI[md5sum] = "e30b67b62a4e30e4504352d0778c622c"
+SRC_URI[sha256sum] = "0d214aa65e085d3e4108a36152cb12f7cd0f4e7fda93b5134b43a9687c975786"
+
+inherit pypi setuptools
+
+PYPI_PACKAGE = "pyperf"
+
+DEPENDS += "${PYTHON_PN}-six-native"
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-contextlib \
+ ${PYTHON_PN}-datetime \
+ ${PYTHON_PN}-fcntl \
+ ${PYTHON_PN}-math \
+ ${PYTHON_PN}-numbers \
+ ${PYTHON_PN}-six \
+ ${PYTHON_PN}-statistics \
+"