summaryrefslogtreecommitdiffstats
path: root/external/meta-python2/recipes-devtools/python/python-pyroute2_0.5.7.bb
diff options
context:
space:
mode:
Diffstat (limited to 'external/meta-python2/recipes-devtools/python/python-pyroute2_0.5.7.bb')
-rw-r--r--external/meta-python2/recipes-devtools/python/python-pyroute2_0.5.7.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/external/meta-python2/recipes-devtools/python/python-pyroute2_0.5.7.bb b/external/meta-python2/recipes-devtools/python/python-pyroute2_0.5.7.bb
new file mode 100644
index 00000000..4ad9746b
--- /dev/null
+++ b/external/meta-python2/recipes-devtools/python/python-pyroute2_0.5.7.bb
@@ -0,0 +1,26 @@
+SUMMARY = "A pure Python netlink and Linux network configuration library"
+LICENSE = "GPLv2 & Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE.GPL.v2;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
+ file://LICENSE.Apache.v2;md5=34281e312165f843a2b7d1f114fe65ce"
+
+SRC_URI[md5sum] = "371683b62314211b8bc9807ac8ef1144"
+SRC_URI[sha256sum] = "963fce07da2841456d39e3b932b071f6de28d23dadfae014022d67a752916f98"
+
+FILESEXTRAPATHS_prepend := "${THISDIR}/python-pyroute2:"
+
+inherit pypi setuptools
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-ctypes \
+ ${PYTHON_PN}-distutils \
+ ${PYTHON_PN}-io \
+ ${PYTHON_PN}-json \
+ ${PYTHON_PN}-logging \
+ ${PYTHON_PN}-multiprocessing \
+ ${PYTHON_PN}-pickle \
+ ${PYTHON_PN}-pkgutil \
+ ${PYTHON_PN}-pprint \
+ ${PYTHON_PN}-shell \
+ ${PYTHON_PN}-subprocess \
+ ${PYTHON_PN}-unixadmin \
+"