summaryrefslogtreecommitdiffstats
path: root/external/meta-python2/recipes-devtools/python/python-pyrtm_0.4.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'external/meta-python2/recipes-devtools/python/python-pyrtm_0.4.2.bb')
-rw-r--r--external/meta-python2/recipes-devtools/python/python-pyrtm_0.4.2.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/external/meta-python2/recipes-devtools/python/python-pyrtm_0.4.2.bb b/external/meta-python2/recipes-devtools/python/python-pyrtm_0.4.2.bb
new file mode 100644
index 00000000..69580cbc
--- /dev/null
+++ b/external/meta-python2/recipes-devtools/python/python-pyrtm_0.4.2.bb
@@ -0,0 +1,39 @@
+SUMMARY = "Python interface for Remember The Milk API"
+AUTHOR = "Sridhar Ratnakumar / srid"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=a53cbc7cb75660694e138ba973c148df"
+
+PYPI_PACKAGE_EXT = "tar.bz2"
+
+SRC_URI[md5sum] = "7c87da94656b620dfe532ca63d642eb8"
+SRC_URI[sha256sum] = "b2d701b25ad3f9a1542057f3eb492c5c1d7dbe2b8d1e8f763043dcc14ee1d933"
+
+inherit pypi setuptools
+
+PACKAGES =+ "${PN}-tests ${PN}-samples"
+
+FILES_${PN}-samples += " \
+ ${PYTHON_SITEPACKAGES_DIR}/rtm/samples \
+"
+
+FILES_${PN}-tests += " \
+ ${PYTHON_SITEPACKAGES_DIR}/rtm/tests \
+"
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-json \
+ ${PYTHON_PN}-logging \
+ ${PYTHON_PN}-netclient \
+"
+
+RDEPENDS_${PN}-samples += " \
+ ${PN} \
+"
+
+RDEPENDS_${PN}-tests += " \
+ ${PN} \
+ ${PYTHON_PN}-unittest \
+"
+
+# meta-python recipe did not follow Debian naming
+PROVIDES += "pyrtm"