summaryrefslogtreecommitdiffstats
path: root/external/meta-python2/recipes-devtools/python/python-pysqlite_2.8.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'external/meta-python2/recipes-devtools/python/python-pysqlite_2.8.3.bb')
-rw-r--r--external/meta-python2/recipes-devtools/python/python-pysqlite_2.8.3.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/external/meta-python2/recipes-devtools/python/python-pysqlite_2.8.3.bb b/external/meta-python2/recipes-devtools/python/python-pysqlite_2.8.3.bb
new file mode 100644
index 00000000..ec8cec42
--- /dev/null
+++ b/external/meta-python2/recipes-devtools/python/python-pysqlite_2.8.3.bb
@@ -0,0 +1,21 @@
+SUMMARY = "DB-API 2.0 interface for SQLite 3.x"
+DESCRIPTION = "pysqlite is an interface to the SQLite 3.x embedded relational \
+database engine. It is almost fully compliant with the Python database API \
+version 2.0 also exposes the unique features of SQLite."
+HOMEPAGE = "http://github.com/ghaering/pysqlite"
+LICENSE = "Zlib"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=28ad4f115e06c88bd737372a453369d8"
+
+SRC_URI[md5sum] = "033f17b8644577715aee55e8832ac9fc"
+SRC_URI[sha256sum] = "17d3335863e8cf8392eea71add33dab3f96d060666fe68ab7382469d307f4490"
+
+inherit pypi setuptools
+
+DEPENDS += "${PYTHON_PN}-pip"
+
+RDEPENDS_${PN}_class-target += "\
+ ${PYTHON_PN}-datetime \
+ sqlite3 \
+"
+
+FILES_${PN}-doc += "${datadir}"