summaryrefslogtreecommitdiffstats
path: root/external/meta-python2/recipes-devtools/python/python-pytest-helpers-namespace_2019.1.8.bb
diff options
context:
space:
mode:
Diffstat (limited to 'external/meta-python2/recipes-devtools/python/python-pytest-helpers-namespace_2019.1.8.bb')
-rw-r--r--external/meta-python2/recipes-devtools/python/python-pytest-helpers-namespace_2019.1.8.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/external/meta-python2/recipes-devtools/python/python-pytest-helpers-namespace_2019.1.8.bb b/external/meta-python2/recipes-devtools/python/python-pytest-helpers-namespace_2019.1.8.bb
new file mode 100644
index 00000000..5d8ee05f
--- /dev/null
+++ b/external/meta-python2/recipes-devtools/python/python-pytest-helpers-namespace_2019.1.8.bb
@@ -0,0 +1,15 @@
+SUMMARY = "PyTest Helpers Namespace"
+DESCRIPTION = "This plugin does not provide any helpers to pytest, it does, however, provide a helpers namespace in pytest which enables you to register helper functions in your conftest.py to be used within your tests without having to import them."
+HOMEPAGE = "https://github.com/saltstack/pytest-helpers-namespace"
+SECTION = "devel/python"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://PKG-INFO;md5=cc99508c43d9d14fd51c7fac622ffd23"
+
+SRC_URI[md5sum] = "04ec1d8750f9b154e782a47cf8b30736"
+SRC_URI[sha256sum] = "4eff23a19f92410c0166f6dffbfa8901d3e14a80e97d70cd08428b6d597771ce"
+
+inherit pypi setuptools
+
+RDEPENDS_${PN} += " \
+ python-pytest \
+ "