summaryrefslogtreecommitdiffstats
path: root/external/meta-python2/recipes-devtools/python/python-pytest-tempdir_2019.10.12.bb
diff options
context:
space:
mode:
Diffstat (limited to 'external/meta-python2/recipes-devtools/python/python-pytest-tempdir_2019.10.12.bb')
-rw-r--r--external/meta-python2/recipes-devtools/python/python-pytest-tempdir_2019.10.12.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/external/meta-python2/recipes-devtools/python/python-pytest-tempdir_2019.10.12.bb b/external/meta-python2/recipes-devtools/python/python-pytest-tempdir_2019.10.12.bb
new file mode 100644
index 00000000..4e8489de
--- /dev/null
+++ b/external/meta-python2/recipes-devtools/python/python-pytest-tempdir_2019.10.12.bb
@@ -0,0 +1,17 @@
+SUMMARY = "Adds support for a predictable and repeatable temporary directory."
+DESCRIPTION = "Adds support for a predictable and repeatable temporary \
+directory through the tempdir fixture which gets cleaned up in the end of the \
+test run session(this behaviour can be disabled)."
+HOMEPAGE = "https://github.com/saltstack/pytest-tempdir"
+SECTION = "devel/python"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://PKG-INFO;md5=9872c3a37cc9baf79a464cd168282be5"
+
+SRC_URI[md5sum] = "79b997d418fb85c2529ab50cd4333689"
+SRC_URI[sha256sum] = "e7d91813a9aa991db87dacdef8cfd3f1657632d731d56d06238c5ffb63ab36d8"
+
+inherit pypi setuptools
+
+RDEPENDS_${PN} += " \
+ python-pytest \
+ "