summaryrefslogtreecommitdiffstats
path: root/external/meta-python2/recipes-devtools/python/python-pyzmq/club-rpath-out.patch
diff options
context:
space:
mode:
Diffstat (limited to 'external/meta-python2/recipes-devtools/python/python-pyzmq/club-rpath-out.patch')
-rw-r--r--external/meta-python2/recipes-devtools/python/python-pyzmq/club-rpath-out.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/external/meta-python2/recipes-devtools/python/python-pyzmq/club-rpath-out.patch b/external/meta-python2/recipes-devtools/python/python-pyzmq/club-rpath-out.patch
new file mode 100644
index 00000000..936f1658
--- /dev/null
+++ b/external/meta-python2/recipes-devtools/python/python-pyzmq/club-rpath-out.patch
@@ -0,0 +1,13 @@
+diff --git a/setup.py b/setup.py
+index d243eaa..98099bc 100755
+--- a/setup.py
++++ b/setup.py
+@@ -192,8 +192,6 @@ def _add_rpath(settings, path):
+ """
+ if sys.platform == 'darwin':
+ settings['extra_link_args'].extend(['-Wl,-rpath','-Wl,%s' % path])
+- else:
+- settings['runtime_library_dirs'].append(path)
+
+ def settings_from_prefix(prefix=None, bundle_libzmq_dylib=False):
+ """load appropriate library/include settings from ZMQ prefix"""