summaryrefslogtreecommitdiffstats
path: root/external/meta-python2/recipes-devtools/python/python-robotframework_3.0.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'external/meta-python2/recipes-devtools/python/python-robotframework_3.0.4.bb')
-rw-r--r--external/meta-python2/recipes-devtools/python/python-robotframework_3.0.4.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/external/meta-python2/recipes-devtools/python/python-robotframework_3.0.4.bb b/external/meta-python2/recipes-devtools/python/python-robotframework_3.0.4.bb
new file mode 100644
index 00000000..d694279b
--- /dev/null
+++ b/external/meta-python2/recipes-devtools/python/python-robotframework_3.0.4.bb
@@ -0,0 +1,28 @@
+
+SUMMARY = "A Python generic test automation framework"
+DESCRIPTION = "Generic open source test atomation framework for acceptance\
+testing and acceptance test-driven development (ATDD). It has easy-to-use\
+tabular test data syntax and it utilizes the keyword-driven testing approach.\
+Its testing capabilities can be extended by test libraries implemented either\
+with Python or Java, and users can create new higher-level keywords from\
+existing ones using the same syntax that is used for creating test cases."
+HOMEPAGE = "http://robotframework.org"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+inherit pypi setuptools
+
+SRC_URI[md5sum] = "ee753415645ff4831ff0d366a0467fe7"
+SRC_URI[sha256sum] = "ab94257cbd848dfca7148e092d233a12853cc7e840ce8231af9cbb5e7f51aa47"
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-ctypes \
+ ${PYTHON_PN}-difflib \
+ ${PYTHON_PN}-docutils \
+ ${PYTHON_PN}-html \
+ ${PYTHON_PN}-pprint \
+ ${PYTHON_PN}-shell \
+ ${PYTHON_PN}-threading \
+ ${PYTHON_PN}-xml \
+ ${PYTHON_PN}-zlib \
+"