summaryrefslogtreecommitdiffstats
path: root/external/meta-python2/recipes-devtools/python/python-sqlalchemy_1.3.12.bb
diff options
context:
space:
mode:
Diffstat (limited to 'external/meta-python2/recipes-devtools/python/python-sqlalchemy_1.3.12.bb')
-rw-r--r--external/meta-python2/recipes-devtools/python/python-sqlalchemy_1.3.12.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/external/meta-python2/recipes-devtools/python/python-sqlalchemy_1.3.12.bb b/external/meta-python2/recipes-devtools/python/python-sqlalchemy_1.3.12.bb
new file mode 100644
index 00000000..15bee0db
--- /dev/null
+++ b/external/meta-python2/recipes-devtools/python/python-sqlalchemy_1.3.12.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "Python SQL toolkit and Object Relational Mapper that gives \
+application developers the full power and flexibility of SQL"
+HOMEPAGE = "http://www.sqlalchemy.org/"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=2f5eb030c48975d5294baf0f5d01af1c"
+
+PYPI_PACKAGE = "SQLAlchemy"
+
+inherit pypi setuptools
+
+SRC_URI[md5sum] = "02a46be841903b60c52a83342d3ced8e"
+SRC_URI[sha256sum] = "bfb8f464a5000b567ac1d350b9090cf081180ec1ab4aa87e7bca12dab25320ec"
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-json \
+ ${PYTHON_PN}-pickle \
+ ${PYTHON_PN}-logging \
+ ${PYTHON_PN}-netclient \
+ ${PYTHON_PN}-numbers \
+ ${PYTHON_PN}-threading \
+"
+