summaryrefslogtreecommitdiffstats
path: root/external/meta-python2/recipes-devtools/python/python-ujson_1.35.bb
diff options
context:
space:
mode:
Diffstat (limited to 'external/meta-python2/recipes-devtools/python/python-ujson_1.35.bb')
-rw-r--r--external/meta-python2/recipes-devtools/python/python-ujson_1.35.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/external/meta-python2/recipes-devtools/python/python-ujson_1.35.bb b/external/meta-python2/recipes-devtools/python/python-ujson_1.35.bb
new file mode 100644
index 00000000..bc982fc5
--- /dev/null
+++ b/external/meta-python2/recipes-devtools/python/python-ujson_1.35.bb
@@ -0,0 +1,17 @@
+SUMMARY = "Ultra fast JSON encoder and decoder for Python"
+DESCRIPTION = "UltraJSON is an ultra fast JSON encoder and decoder written in pure C with bindings for Python 2.5+ and 3."
+
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=88df8e78b9edfd744953862179f2d14e"
+
+SRC_URI[md5sum] = "42f77b0cce686dfa4da2e68480b1dd24"
+SRC_URI[sha256sum] = "f66073e5506e91d204ab0c614a148d5aa938bdbf104751be66f8ad7a222f5f86"
+
+inherit pypi setuptools
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-datetime \
+ ${PYTHON_PN}-numbers \
+ "
+
+BBCLASSEXTEND = "native nativesdk"