summaryrefslogtreecommitdiffstats
path: root/external/meta-python2/recipes-devtools/python/python-urllib3_1.25.7.bb
diff options
context:
space:
mode:
Diffstat (limited to 'external/meta-python2/recipes-devtools/python/python-urllib3_1.25.7.bb')
-rw-r--r--external/meta-python2/recipes-devtools/python/python-urllib3_1.25.7.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/external/meta-python2/recipes-devtools/python/python-urllib3_1.25.7.bb b/external/meta-python2/recipes-devtools/python/python-urllib3_1.25.7.bb
new file mode 100644
index 00000000..6487d89b
--- /dev/null
+++ b/external/meta-python2/recipes-devtools/python/python-urllib3_1.25.7.bb
@@ -0,0 +1,23 @@
+SUMMARY = "Python HTTP library with thread-safe connection pooling, file post support, sanity friendly, and more"
+HOMEPAGE = "https://github.com/shazow/urllib3"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=65715c2eb961313d71b297dd5a04f85e"
+
+SRC_URI[md5sum] = "85e1e3925f8c1095172bff343f3312ed"
+SRC_URI[sha256sum] = "f3c5fd51747d450d4dcf6f923c81f78f811aab8205fda64b0aba34a4e48b0745"
+
+inherit pypi setuptools
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-certifi \
+ ${PYTHON_PN}-cryptography \
+ ${PYTHON_PN}-email \
+ ${PYTHON_PN}-idna \
+ ${PYTHON_PN}-netclient \
+ ${PYTHON_PN}-pyopenssl \
+ ${PYTHON_PN}-threading \
+"
+
+CVE_PRODUCT = "urllib3"
+
+BBCLASSEXTEND = "native nativesdk"