summaryrefslogtreecommitdiffstats
path: root/external/meta-python2/recipes-devtools/python/python-which_1.1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'external/meta-python2/recipes-devtools/python/python-which_1.1.0.bb')
-rw-r--r--external/meta-python2/recipes-devtools/python/python-which_1.1.0.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/external/meta-python2/recipes-devtools/python/python-which_1.1.0.bb b/external/meta-python2/recipes-devtools/python/python-which_1.1.0.bb
new file mode 100644
index 00000000..901fdc76
--- /dev/null
+++ b/external/meta-python2/recipes-devtools/python/python-which_1.1.0.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "which.py -- a portable GNU which replacement"
+HOMEPAGE = "http://code.google.com/p/which/"
+SECTION = "devel/python"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=030b09798681482b9ad12ac47be496ea"
+
+inherit setuptools pypi python-dir
+
+SRCREV = "425bdeeb2d87c36e2313dc4b8d69ff2bb5a02ee9"
+PYPI_SRC_URI = "git://github.com/trentm/which"
+
+S = "${WORKDIR}/git"
+
+do_install_append() {
+ rmdir -p --ignore-fail-on-non-empty ${D}${STAGING_BINDIR_NATIVE}
+ rmdir -p --ignore-fail-on-non-empty ${D}${datadir}
+}
+
+BBCLASSEXTEND = "native nativesdk"