summaryrefslogtreecommitdiffstats
path: root/external/meta-python2/recipes-devtools/python/python-zopeinterface_4.7.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'external/meta-python2/recipes-devtools/python/python-zopeinterface_4.7.1.bb')
-rw-r--r--external/meta-python2/recipes-devtools/python/python-zopeinterface_4.7.1.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/external/meta-python2/recipes-devtools/python/python-zopeinterface_4.7.1.bb b/external/meta-python2/recipes-devtools/python/python-zopeinterface_4.7.1.bb
new file mode 100644
index 00000000..d2ef64f1
--- /dev/null
+++ b/external/meta-python2/recipes-devtools/python/python-zopeinterface_4.7.1.bb
@@ -0,0 +1,25 @@
+SUMMARY = "Interface definitions for Zope products"
+LICENSE = "ZPL-2.1"
+LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=e54fd776274c1b7423ec128974bd9d46"
+
+SRC_URI[md5sum] = "1bc66758275c5eb66d169acba3c8e50e"
+SRC_URI[sha256sum] = "4bb937e998be9d5e345f486693e477ba79e4344674484001a0b646be1d530487"
+
+PYPI_PACKAGE = "zope.interface"
+
+PACKAGES =. "${PN}-test "
+
+RPROVIDES_${PN} += "zope-interfaces"
+
+RDEPENDS_${PN}_class-target += "${PYTHON_PN}-datetime"
+
+FILES_${PN}-dbg += "${PYTHON_SITEPACKAGES_DIR}/*.egg/*/*/.debug"
+FILES_${PN}-dev += "${PYTHON_SITEPACKAGES_DIR}/zope/interface/*.c"
+FILES_${PN}-doc += "${PYTHON_SITEPACKAGES_DIR}/zope/interface/*.txt"
+FILES_${PN}-test += " \
+ ${PYTHON_SITEPACKAGES_DIR}/zope/interface/tests \
+ ${PYTHON_SITEPACKAGES_DIR}/zope/interface/common/tests \
+"
+inherit pypi setuptools
+
+RDEPENDS_${PN}-test += "python-unittest python-doctest"