summaryrefslogtreecommitdiffstats
path: root/external/meta-python2/recipes-devtools/python/python/05-enable-ctypes-cross-build.patch
diff options
context:
space:
mode:
Diffstat (limited to 'external/meta-python2/recipes-devtools/python/python/05-enable-ctypes-cross-build.patch')
-rw-r--r--external/meta-python2/recipes-devtools/python/python/05-enable-ctypes-cross-build.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/external/meta-python2/recipes-devtools/python/python/05-enable-ctypes-cross-build.patch b/external/meta-python2/recipes-devtools/python/python/05-enable-ctypes-cross-build.patch
new file mode 100644
index 00000000..5cc87424
--- /dev/null
+++ b/external/meta-python2/recipes-devtools/python/python/05-enable-ctypes-cross-build.patch
@@ -0,0 +1,27 @@
+Rebased for python 2.7.9
+
+Upstream-Status: Inappropriate [embedded specific]
+
+# CTypes need to know the actual host we are building on.
+# Signed-Off: Michael Dietrich <mdt@emdete.de>
+
+Index: Python-2.7.9/setup.py
+===================================================================
+--- Python-2.7.9.orig/setup.py
++++ Python-2.7.9/setup.py
+@@ -2028,12 +2028,12 @@ class PyBuildExt(build_ext):
+
+ # Pass empty CFLAGS because we'll just append the resulting
+ # CFLAGS to Python's; -g or -O2 is to be avoided.
+- cmd = "cd %s && env CFLAGS='' '%s/configure' %s" \
+- % (ffi_builddir, ffi_srcdir, " ".join(config_args))
++ cmd = "(cd %s && autoconf -W cross) && (cd %s && env CFLAGS='' '%s/configure' %s)" \
++ % (ffi_srcdir, ffi_builddir, ffi_srcdir, " ".join(config_args))
+
+ res = os.system(cmd)
+ if res or not os.path.exists(ffi_configfile):
+- print "Failed to configure _ctypes module"
++ print "Failed to configure _ctypes module (res=%d) or missing conffile=%s" % ( res, ffi_configfile )
+ return False
+
+ fficonfig = {}