summaryrefslogtreecommitdiffstats
path: root/external/meta-sdl/recipes-automotive/sdl-core/sdl-core/0004-Change-to-use-standard-libdir.patch
diff options
context:
space:
mode:
Diffstat (limited to 'external/meta-sdl/recipes-automotive/sdl-core/sdl-core/0004-Change-to-use-standard-libdir.patch')
-rw-r--r--external/meta-sdl/recipes-automotive/sdl-core/sdl-core/0004-Change-to-use-standard-libdir.patch93
1 files changed, 0 insertions, 93 deletions
diff --git a/external/meta-sdl/recipes-automotive/sdl-core/sdl-core/0004-Change-to-use-standard-libdir.patch b/external/meta-sdl/recipes-automotive/sdl-core/sdl-core/0004-Change-to-use-standard-libdir.patch
deleted file mode 100644
index 0ec53702..00000000
--- a/external/meta-sdl/recipes-automotive/sdl-core/sdl-core/0004-Change-to-use-standard-libdir.patch
+++ /dev/null
@@ -1,93 +0,0 @@
-From 855e1548269d830b07962a72fa17100193de35f3 Mon Sep 17 00:00:00 2001
-From: Phong Tran <tranmanphong@gmail.com>
-Date: Sun, 17 Jul 2016 14:03:13 +0700
-Subject: [PATCH 04/10] Change to use standard libdir
-
-The lib*.so should be in /usr/lib path.
-
-Signed-off-by: Phong Tran <tranmanphong@gmail.com>
-
-%% original patch: 0004-Change-to-use-standard-libdir.patch
----
- src/components/policy/policy_external/CMakeLists.txt | 4 ++--
- src/components/policy/policy_regular/CMakeLists.txt | 2 +-
- src/components/remote_control/CMakeLists.txt | 2 +-
- src/components/utils/CMakeLists.txt | 2 +-
- src/plugins/appenders/CMakeLists.txt | 2 +-
- 5 files changed, 6 insertions(+), 6 deletions(-)
-
-diff --git a/src/components/policy/policy_external/CMakeLists.txt b/src/components/policy/policy_external/CMakeLists.txt
-index 8d04f20..7a421be 100644
---- a/src/components/policy/policy_external/CMakeLists.txt
-+++ b/src/components/policy/policy_external/CMakeLists.txt
-@@ -30,7 +30,7 @@
-
- # --- Policy
- set(target Policy)
--set(install_destination bin)
-+set(install_destination ${CMAKE_INSTALL_LIBDIR})
- set(copy_destination ${CMAKE_BINARY_DIR}/src/appMain)
- set(library_name ${CMAKE_SHARED_LIBRARY_PREFIX}${target}${CMAKE_SHARED_LIBRARY_SUFFIX})
-
-@@ -92,7 +92,7 @@ add_custom_target(copy_library_${target} ALL
- COMMENT "Copying library ${library_name}")
-
- install(TARGETS ${target}
-- DESTINATION ${install_destination}
-+ DESTINATION ${CMAKE_INSTALL_LIBDIR}
- PERMISSIONS OWNER_READ OWNER_WRITE OWNER_EXECUTE
- GROUP_READ GROUP_EXECUTE
- WORLD_READ WORLD_EXECUTE
-diff --git a/src/components/policy/policy_regular/CMakeLists.txt b/src/components/policy/policy_regular/CMakeLists.txt
-index c7b9c06..61ddecb 100644
---- a/src/components/policy/policy_regular/CMakeLists.txt
-+++ b/src/components/policy/policy_regular/CMakeLists.txt
-@@ -102,7 +102,7 @@ endif()
-
- set(LIBRARY_NAME ${CMAKE_SHARED_LIBRARY_PREFIX}Policy${CMAKE_SHARED_LIBRARY_SUFFIX})
- set(TARGET_LOCATION ${CMAKE_CURRENT_BINARY_DIR}/${LIBRARY_NAME})
--set(INSTALL_DESTINATION bin)
-+set(INSTALL_DESTINATION ${CMAKE_INSTALL_LIBDIR})
- set(COPY_DESTINATION ${CMAKE_BINARY_DIR}/src/appMain)
-
- add_custom_target(copy_policy_library ALL
-diff --git a/src/components/remote_control/CMakeLists.txt b/src/components/remote_control/CMakeLists.txt
-index a320273..c1d2c51 100644
---- a/src/components/remote_control/CMakeLists.txt
-+++ b/src/components/remote_control/CMakeLists.txt
-@@ -1,5 +1,5 @@
- set(target "RemoteControlModule")
--set(install_destination ${CMAKE_BINARY_DIR}/bin/plugins)
-+set(install_destination ${CMAKE_INSTALL_LIBDIR})
- if (ENABLE_GCOV)
- set(GCOV_FLAGS "-ftest-coverage -fprofile-arcs")
- else()
-diff --git a/src/components/utils/CMakeLists.txt b/src/components/utils/CMakeLists.txt
-index 51835c1..abb4cd7 100644
---- a/src/components/utils/CMakeLists.txt
-+++ b/src/components/utils/CMakeLists.txt
-@@ -124,7 +124,7 @@ if(BUILD_TESTS)
- endif()
-
- install(TARGETS "Utils"
-- DESTINATION bin
-+ DESTINATION ${CMAKE_INSTALL_LIBDIR}
- PERMISSIONS
- OWNER_READ OWNER_WRITE
- GROUP_READ
-diff --git a/src/plugins/appenders/CMakeLists.txt b/src/plugins/appenders/CMakeLists.txt
-index 3d18e62..4c39f8b 100644
---- a/src/plugins/appenders/CMakeLists.txt
-+++ b/src/plugins/appenders/CMakeLists.txt
-@@ -46,7 +46,7 @@ target_link_libraries(appenders ${LIBRARIES})
- add_dependencies(appenders install-3rd_party_logger)
-
- install(TARGETS appenders
-- DESTINATION bin
-+ DESTINATION ${CMAKE_INSTALL_LIBDIR}
- PERMISSIONS
- OWNER_READ OWNER_WRITE OWNER_EXECUTE
- GROUP_READ GROUP_EXECUTE
---
-2.7.4
-