summaryrefslogtreecommitdiffstats
path: root/external/meta-sdl/recipes-automotive/sdl-core/sdl-core/0006-Install-the-configure-file-to-sysconf-dir.patch
diff options
context:
space:
mode:
Diffstat (limited to 'external/meta-sdl/recipes-automotive/sdl-core/sdl-core/0006-Install-the-configure-file-to-sysconf-dir.patch')
-rw-r--r--external/meta-sdl/recipes-automotive/sdl-core/sdl-core/0006-Install-the-configure-file-to-sysconf-dir.patch59
1 files changed, 0 insertions, 59 deletions
diff --git a/external/meta-sdl/recipes-automotive/sdl-core/sdl-core/0006-Install-the-configure-file-to-sysconf-dir.patch b/external/meta-sdl/recipes-automotive/sdl-core/sdl-core/0006-Install-the-configure-file-to-sysconf-dir.patch
deleted file mode 100644
index 0dd00ebf..00000000
--- a/external/meta-sdl/recipes-automotive/sdl-core/sdl-core/0006-Install-the-configure-file-to-sysconf-dir.patch
+++ /dev/null
@@ -1,59 +0,0 @@
-From ca30ea45d91b9ec15ea456ce4492575bee571c56 Mon Sep 17 00:00:00 2001
-From: Phong Tran <tranmanphong@gmail.com>
-Date: Tue, 19 Dec 2017 23:43:56 +0700
-Subject: [PATCH 06/10] Install the configure file to sysconf dir
-
-Use CMAKE_INSTALL_SYSCONFDIR for sdl configure files.
-
-%% original patch: 0006-Install-the-configure-file-to-sysconf-dir.patch
----
- src/appMain/CMakeLists.txt | 22 +++++++++++-----------
- 1 file changed, 11 insertions(+), 11 deletions(-)
-
-diff --git a/src/appMain/CMakeLists.txt b/src/appMain/CMakeLists.txt
-index 5148676..f6d8093 100644
---- a/src/appMain/CMakeLists.txt
-+++ b/src/appMain/CMakeLists.txt
-@@ -155,15 +155,15 @@ target_link_libraries(${PROJECT} ${LIBRARIES})
-
- add_dependencies(${PROJECT} Policy)
-
--file(COPY ${CMAKE_CURRENT_SOURCE_DIR}/log4cxx.properties DESTINATION ${CMAKE_CURRENT_BINARY_DIR})
--file(COPY ${CMAKE_CURRENT_SOURCE_DIR}/audio.8bit.wav DESTINATION ${CMAKE_CURRENT_BINARY_DIR})
--file(COPY ${CMAKE_CURRENT_SOURCE_DIR}/test.txt DESTINATION ${CMAKE_CURRENT_BINARY_DIR})
--file(COPY ${CMAKE_CURRENT_SOURCE_DIR}/smartDeviceLink.ini DESTINATION ${CMAKE_CURRENT_BINARY_DIR})
--file(COPY ${CMAKE_CURRENT_SOURCE_DIR}/hmi_capabilities.json DESTINATION ${CMAKE_CURRENT_BINARY_DIR})
--file(COPY ${CMAKE_CURRENT_SOURCE_DIR}/sdl_preloaded_pt.json DESTINATION ${CMAKE_CURRENT_BINARY_DIR})
--file(COPY ${CMAKE_CURRENT_SOURCE_DIR}/sample_policy_manager.py DESTINATION ${CMAKE_CURRENT_BINARY_DIR})
--file(COPY ${CMAKE_CURRENT_SOURCE_DIR}/start.sh DESTINATION ${CMAKE_CURRENT_BINARY_DIR})
--file(COPY ${CMAKE_CURRENT_SOURCE_DIR}/start_external_proprietary.sh DESTINATION ${CMAKE_CURRENT_BINARY_DIR})
-+install(FILES ${CMAKE_CURRENT_SOURCE_DIR}/log4cxx.properties DESTINATION ${CMAKE_INSTALL_SYSCONFDIR}/smartdevicelink COMPONENT config)
-+install(FILES ${CMAKE_CURRENT_SOURCE_DIR}/audio.8bit.wav DESTINATION ${CMAKE_INSTALL_SYSCONFDIR}/smartdevicelink COMPONENT config)
-+install(FILES ${CMAKE_CURRENT_SOURCE_DIR}/test.txt DESTINATION ${CMAKE_INSTALL_SYSCONFDIR}/smartdevicelink COMPONENT config)
-+install(FILES ${CMAKE_CURRENT_SOURCE_DIR}/smartDeviceLink.ini DESTINATION ${CMAKE_INSTALL_SYSCONFDIR}/smartdevicelink COMPONENT config)
-+install(FILES ${CMAKE_CURRENT_SOURCE_DIR}/hmi_capabilities.json DESTINATION ${CMAKE_INSTALL_SYSCONFDIR}/smartdevicelink COMPONENT config)
-+install(FILES ${CMAKE_CURRENT_SOURCE_DIR}/sdl_preloaded_pt.json DESTINATION ${CMAKE_INSTALL_SYSCONFDIR}/smartdevicelink COMPONENT config)
-+install(FILES ${CMAKE_CURRENT_SOURCE_DIR}/sample_policy_manager.py DESTINATION ${CMAKE_INSTALL_SYSCONFDIR}/smartdevicelink COMPONENT config)
-+install(FILES ${CMAKE_CURRENT_SOURCE_DIR}/start.sh DESTINATION ${CMAKE_INSTALL_SYSCONFDIR}/smartdevicelink COMPONENT config)
-+install(FILES ${CMAKE_CURRENT_SOURCE_DIR}/start_external_proprietary.sh DESTINATION ${CMAKE_INSTALL_SYSCONFDIR}/smartdevicelink COMPONENT config)
- if (CMAKE_SYSTEM_NAME STREQUAL "QNX")
- file(COPY ${CMAKE_CURRENT_SOURCE_DIR}/init_policy.sh DESTINATION ${CMAKE_CURRENT_BINARY_DIR})
- endif ()
-@@ -215,12 +215,12 @@ install(
- FILES log4cxx.properties audio.8bit.wav test.txt smartDeviceLink.ini
- hmi_capabilities.json sdl_preloaded_pt.json sample_policy_manager.py
- ${CMAKE_SOURCE_DIR}/mycert.pem ${CMAKE_SOURCE_DIR}/mykey.pem
-- DESTINATION bin
-+ DESTINATION ${CMAKE_INSTALL_SYSCONFDIR}/smartdevicelink
- )
-
- install(
- FILES sdl_preloaded_pt.json
-- DESTINATION bin
-+ DESTINATION ${CMAKE_INSTALL_SYSCONFDIR}/smartdevicelink
- )
-
- if (${QT_HMI})
---
-2.7.4
-