summaryrefslogtreecommitdiffstats
path: root/external/meta-security/meta-integrity/conf/layer.conf
diff options
context:
space:
mode:
Diffstat (limited to 'external/meta-security/meta-integrity/conf/layer.conf')
-rw-r--r--external/meta-security/meta-integrity/conf/layer.conf28
1 files changed, 28 insertions, 0 deletions
diff --git a/external/meta-security/meta-integrity/conf/layer.conf b/external/meta-security/meta-integrity/conf/layer.conf
new file mode 100644
index 00000000..b4edac38
--- /dev/null
+++ b/external/meta-security/meta-integrity/conf/layer.conf
@@ -0,0 +1,28 @@
+# We have a conf and classes directory, add to BBPATH
+BBPATH =. "${LAYERDIR}:"
+
+# We have a packages directory, add to BBFILES
+BBFILES := "${BBFILES} \
+ ${LAYERDIR}/recipes-*/*/*.bb \
+ ${LAYERDIR}/recipes-*/*/*.bbappend"
+
+BBFILE_COLLECTIONS += "integrity"
+BBFILE_PATTERN_integrity := "^${LAYERDIR}/"
+BBFILE_PRIORITY_integrity = "6"
+
+# Set a variable to get to the top of the metadata location. Needed
+# for finding scripts (when following the README.md instructions) and
+# default debug keys (in ima-evm-rootfs.bbclass).
+INTEGRITY_BASE := '${LAYERDIR}'
+
+# We must not export this path to all shell scripts (as in "export
+# INTEGRITY_BASE"), because that causes problems with sstate (becames
+# dependent on location of the layer). Exporting it to just the
+# interactive shell is enough.
+OE_TERMINAL_EXPORTS += "INTEGRITY_BASE"
+
+LAYERSERIES_COMPAT_integrity = "dunfell"
+# ima-evm-utils depends on keyutils from meta-oe
+LAYERDEPENDS_integrity = "core openembedded-layer"
+
+BBLAYERS_LAYERINDEX_NAME_integrity = "meta-integrity"