summaryrefslogtreecommitdiffstats
path: root/external/meta-updater-raspberrypi/recipes-bsp/u-boot-otascript/u-boot-otascript.bb
diff options
context:
space:
mode:
Diffstat (limited to 'external/meta-updater-raspberrypi/recipes-bsp/u-boot-otascript/u-boot-otascript.bb')
-rw-r--r--external/meta-updater-raspberrypi/recipes-bsp/u-boot-otascript/u-boot-otascript.bb8
1 files changed, 4 insertions, 4 deletions
diff --git a/external/meta-updater-raspberrypi/recipes-bsp/u-boot-otascript/u-boot-otascript.bb b/external/meta-updater-raspberrypi/recipes-bsp/u-boot-otascript/u-boot-otascript.bb
index 4dceb27c..0ecd792b 100644
--- a/external/meta-updater-raspberrypi/recipes-bsp/u-boot-otascript/u-boot-otascript.bb
+++ b/external/meta-updater-raspberrypi/recipes-bsp/u-boot-otascript/u-boot-otascript.bb
@@ -16,13 +16,13 @@ S = "${WORKDIR}"
inherit deploy
do_deploy() {
- install -d ${DEPLOYDIR}/bcm2835-bootfiles
+ install -d ${DEPLOYDIR}/${BOOTFILES_DIR_NAME}
- mkimage -A arm -O linux -T script -C none -a 0 -e 0 -n "Ostree boot script" -d ${S}/boot.scr ${DEPLOYDIR}/bcm2835-bootfiles/boot.scr
- install -m 0755 ${S}/uEnv.txt ${DEPLOYDIR}/bcm2835-bootfiles/uEnv.txt
+ mkimage -A arm -O linux -T script -C none -a 0 -e 0 -n "Ostree boot script" -d ${S}/boot.scr ${DEPLOYDIR}/${BOOTFILES_DIR_NAME}/boot.scr
+ install -m 0755 ${S}/uEnv.txt ${DEPLOYDIR}/${BOOTFILES_DIR_NAME}/uEnv.txt
}
addtask deploy before do_package after do_install
-do_deploy[dirs] += "${DEPLOYDIR}/bcm2835-bootfiles"
+do_deploy[dirs] += "${DEPLOYDIR}/${BOOTFILES_DIR_NAME}"
PACKAGE_ARCH = "${MACHINE_ARCH}"