summaryrefslogtreecommitdiffstats
path: root/external/meta-updater-raspberrypi/recipes-bsp/u-boot/libubootenv_%.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'external/meta-updater-raspberrypi/recipes-bsp/u-boot/libubootenv_%.bbappend')
-rw-r--r--external/meta-updater-raspberrypi/recipes-bsp/u-boot/libubootenv_%.bbappend10
1 files changed, 10 insertions, 0 deletions
diff --git a/external/meta-updater-raspberrypi/recipes-bsp/u-boot/libubootenv_%.bbappend b/external/meta-updater-raspberrypi/recipes-bsp/u-boot/libubootenv_%.bbappend
new file mode 100644
index 00000000..af8a7445
--- /dev/null
+++ b/external/meta-updater-raspberrypi/recipes-bsp/u-boot/libubootenv_%.bbappend
@@ -0,0 +1,10 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+
+SRC_URI_append_rpi = " \
+ file://fw_env.config \
+ "
+
+do_install_append_rpi () {
+ install -d ${D}${sysconfdir}
+ install -m 0644 ${WORKDIR}/fw_env.config ${D}${sysconfdir}/fw_env.config
+}