summaryrefslogtreecommitdiffstats
path: root/external/meta-updater/recipes-test/demo-network-config/primary-network-config.bb
diff options
context:
space:
mode:
Diffstat (limited to 'external/meta-updater/recipes-test/demo-network-config/primary-network-config.bb')
-rw-r--r--external/meta-updater/recipes-test/demo-network-config/primary-network-config.bb10
1 files changed, 4 insertions, 6 deletions
diff --git a/external/meta-updater/recipes-test/demo-network-config/primary-network-config.bb b/external/meta-updater/recipes-test/demo-network-config/primary-network-config.bb
index d840a951..7ee873f4 100644
--- a/external/meta-updater/recipes-test/demo-network-config/primary-network-config.bb
+++ b/external/meta-updater/recipes-test/demo-network-config/primary-network-config.bb
@@ -2,22 +2,20 @@ DESCRIPTION = "Sample network configuration for an Uptane Primary"
LICENSE = "MPL-2.0"
LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MPL-2.0;md5=815ca599c9df247a0c7f619bab123dad"
-inherit allarch
-
SRC_URI = "\
file://27-dhcp-client-external.network \
"
-FILES_${PN} = "/usr/lib/systemd/network"
+FILES_${PN} = "${libdir}/systemd/network"
PR = "1"
do_install() {
- install -d ${D}/usr/lib/systemd/network
- install -m 0644 ${WORKDIR}/27-dhcp-client-external.network ${D}/usr/lib/systemd/network/
+ install -d ${D}${libdir}/systemd/network
+ install -m 0644 ${WORKDIR}/27-dhcp-client-external.network ${D}${libdir}/systemd/network/
}
-PRIMARY_IP ?= "10.0.3.1"
+PRIMARY_IP ?= "192.168.254.1"
IP_ADDR = "${PRIMARY_IP}"
CONF_TYPE ?= "${@ 'multihomed' if d.getVar('MACHINE') == 'raspberrypi3' and d.getVar('RPI_WIFI_ENABLE') != '1' else 'static'}"