summaryrefslogtreecommitdiffstats
path: root/external/meta-virtualization/recipes-containers/docker-compose/python3-docker-compose_1.25.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'external/meta-virtualization/recipes-containers/docker-compose/python3-docker-compose_1.25.4.bb')
-rw-r--r--external/meta-virtualization/recipes-containers/docker-compose/python3-docker-compose_1.25.4.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/external/meta-virtualization/recipes-containers/docker-compose/python3-docker-compose_1.25.4.bb b/external/meta-virtualization/recipes-containers/docker-compose/python3-docker-compose_1.25.4.bb
new file mode 100644
index 00000000..2dcad1e3
--- /dev/null
+++ b/external/meta-virtualization/recipes-containers/docker-compose/python3-docker-compose_1.25.4.bb
@@ -0,0 +1,38 @@
+SUMMARY = "Multi-container orchestration for Docker"
+HOMEPAGE = "https://www.docker.com/"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=435b266b3899aa8a959f17d41c56def8"
+
+inherit pypi setuptools3
+
+SRC_URI[md5sum] = "893fbb804a9057d6c470b5312407e0d1"
+SRC_URI[sha256sum] = "fabae2bee4abfa7bdd09125b6bbdcdda81f946c7b16e3ccc6bb2d821ef6488f3"
+
+SRC_URI += "file://0001-setup.py-remove-maximum-version-requirements.patch \
+ file://0001-setup.py-import-fastentrypoints.patch \
+ "
+
+DEPENDS += "${PYTHON_PN}-fastentrypoints-native"
+
+RDEPENDS_${PN} = "\
+ ${PYTHON_PN}-cached-property \
+ ${PYTHON_PN}-certifi \
+ ${PYTHON_PN}-chardet \
+ ${PYTHON_PN}-colorama \
+ ${PYTHON_PN}-docker \
+ ${PYTHON_PN}-docker-pycreds \
+ ${PYTHON_PN}-dockerpty \
+ ${PYTHON_PN}-docopt \
+ ${PYTHON_PN}-fcntl \
+ ${PYTHON_PN}-idna \
+ ${PYTHON_PN}-jsonschema \
+ ${PYTHON_PN}-misc \
+ ${PYTHON_PN}-paramiko \
+ ${PYTHON_PN}-pyyaml \
+ ${PYTHON_PN}-requests \
+ ${PYTHON_PN}-six \
+ ${PYTHON_PN}-terminal \
+ ${PYTHON_PN}-texttable \
+ ${PYTHON_PN}-urllib3 \
+ ${PYTHON_PN}-websocket-client \
+"