summaryrefslogtreecommitdiffstats
path: root/external/poky/meta/recipes-connectivity/iw/iw_5.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'external/poky/meta/recipes-connectivity/iw/iw_5.4.bb')
-rw-r--r--external/poky/meta/recipes-connectivity/iw/iw_5.4.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/external/poky/meta/recipes-connectivity/iw/iw_5.4.bb b/external/poky/meta/recipes-connectivity/iw/iw_5.4.bb
new file mode 100644
index 00000000..9f58e497
--- /dev/null
+++ b/external/poky/meta/recipes-connectivity/iw/iw_5.4.bb
@@ -0,0 +1,32 @@
+SUMMARY = "nl80211 based CLI configuration utility for wireless devices"
+DESCRIPTION = "iw is a new nl80211 based CLI configuration utility for \
+wireless devices. It supports almost all new drivers that have been added \
+to the kernel recently. "
+HOMEPAGE = "http://wireless.kernel.org/en/users/Documentation/iw"
+SECTION = "base"
+LICENSE = "BSD-2-Clause"
+LIC_FILES_CHKSUM = "file://COPYING;md5=878618a5c4af25e9b93ef0be1a93f774"
+
+DEPENDS = "libnl"
+
+SRC_URI = "http://www.kernel.org/pub/software/network/iw/${BP}.tar.gz \
+ file://0001-iw-version.sh-don-t-use-git-describe-for-versioning.patch \
+ file://separate-objdir.patch \
+"
+
+SRC_URI[md5sum] = "08a4f581a39dc62fa85d3af796d844b6"
+SRC_URI[sha256sum] = "943cd2446a6c7242fded3766d054ab2a214a3514b9a8b7e942fed8fb13c1370c"
+
+inherit pkgconfig
+
+EXTRA_OEMAKE = "\
+ -f '${S}/Makefile' \
+ \
+ 'PREFIX=${prefix}' \
+ 'SBINDIR=${sbindir}' \
+ 'MANDIR=${mandir}' \
+"
+
+do_install() {
+ oe_runmake 'DESTDIR=${D}' install
+}