summaryrefslogtreecommitdiffstats
path: root/external/poky/meta/recipes-core/meta/uninative-tarball.bb
diff options
context:
space:
mode:
Diffstat (limited to 'external/poky/meta/recipes-core/meta/uninative-tarball.bb')
-rw-r--r--external/poky/meta/recipes-core/meta/uninative-tarball.bb5
1 files changed, 3 insertions, 2 deletions
diff --git a/external/poky/meta/recipes-core/meta/uninative-tarball.bb b/external/poky/meta/recipes-core/meta/uninative-tarball.bb
index e0cb9ffe..39638eb8 100644
--- a/external/poky/meta/recipes-core/meta/uninative-tarball.bb
+++ b/external/poky/meta/recipes-core/meta/uninative-tarball.bb
@@ -16,6 +16,7 @@ TOOLCHAIN_HOST_TASK = "\
nativesdk-glibc-gconv-libjis \
nativesdk-patchelf \
nativesdk-libxcrypt \
+ nativesdk-libxcrypt-compat \
nativesdk-libnss-nis \
"
@@ -57,7 +58,7 @@ fakeroot create_sdk_files() {
}
-fakeroot tar_sdk() {
+fakeroot archive_sdk() {
cd ${SDK_OUTPUT}/${SDKPATH}
DEST="./${SDK_ARCH}-${SDK_OS}"
@@ -65,5 +66,5 @@ fakeroot tar_sdk() {
rm sysroots -rf
patchelf --set-interpreter ${@''.join('a' for n in range(1024))} $DEST/usr/bin/patchelf
mv $DEST/usr/bin/patchelf $DEST/usr/bin/patchelf-uninative
- tar ${SDKTAROPTS} -c -j --file=${SDKDEPLOYDIR}/${TOOLCHAIN_OUTPUTNAME}.tar.bz2 .
+ ${SDK_ARCHIVE_CMD}
}