summaryrefslogtreecommitdiffstats
path: root/external/poky/meta/recipes-devtools/go/go_1.14.bb
diff options
context:
space:
mode:
Diffstat (limited to 'external/poky/meta/recipes-devtools/go/go_1.14.bb')
-rw-r--r--external/poky/meta/recipes-devtools/go/go_1.14.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/external/poky/meta/recipes-devtools/go/go_1.14.bb b/external/poky/meta/recipes-devtools/go/go_1.14.bb
new file mode 100644
index 00000000..bc90a132
--- /dev/null
+++ b/external/poky/meta/recipes-devtools/go/go_1.14.bb
@@ -0,0 +1,14 @@
+require go-${PV}.inc
+require go-target.inc
+
+export GOBUILDMODE=""
+export CGO_ENABLED_riscv64 = ""
+# Add pie to GOBUILDMODE to satisfy "textrel" QA checking, but mips/riscv
+# doesn't support -buildmode=pie, so skip the QA checking for mips/riscv and its
+# variants.
+python() {
+ if 'mips' in d.getVar('TARGET_ARCH',True) or 'riscv' in d.getVar('TARGET_ARCH',True):
+ d.appendVar('INSANE_SKIP_%s' % d.getVar('PN',True), " textrel")
+ else:
+ d.setVar('GOBUILDMODE', 'pie')
+}