summaryrefslogtreecommitdiffstats
path: root/external/poky/meta/recipes-devtools/librepo/librepo_1.11.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'external/poky/meta/recipes-devtools/librepo/librepo_1.11.2.bb')
-rw-r--r--external/poky/meta/recipes-devtools/librepo/librepo_1.11.2.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/external/poky/meta/recipes-devtools/librepo/librepo_1.11.2.bb b/external/poky/meta/recipes-devtools/librepo/librepo_1.11.2.bb
new file mode 100644
index 00000000..6a0a59f8
--- /dev/null
+++ b/external/poky/meta/recipes-devtools/librepo/librepo_1.11.2.bb
@@ -0,0 +1,27 @@
+SUMMARY = "A library providing C and Python (libcURL like) API \
+ for downloading linux repository metadata and packages."
+LICENSE = "LGPLv2.1"
+LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
+
+SRC_URI = "git://github.com/rpm-software-management/librepo.git \
+ file://0002-Do-not-try-to-obtain-PYTHON_INSTALL_DIR-by-running-p.patch \
+ file://0004-Set-gpgme-variables-with-pkg-config-not-with-cmake-m.patch \
+ "
+
+SRCREV = "67c2d1f83f1bf87be3f26ba730fce7fbdf0c9fba"
+
+S = "${WORKDIR}/git"
+
+DEPENDS = "curl glib-2.0 openssl attr gpgme libxml2"
+
+inherit cmake distutils3-base pkgconfig
+
+EXTRA_OECMAKE = " \
+ -DPYTHON_INSTALL_DIR=${PYTHON_SITEPACKAGES_DIR} \
+ -DPYTHON_DESIRED=3 \
+ -DENABLE_TESTS=OFF \
+ -DENABLE_DOCS=OFF \
+ -DWITH_ZCHUNK=OFF \
+"
+
+BBCLASSEXTEND = "native nativesdk"