summaryrefslogtreecommitdiffstats
path: root/external/poky/meta/recipes-devtools/python/python3-dbus_1.2.16.bb
diff options
context:
space:
mode:
Diffstat (limited to 'external/poky/meta/recipes-devtools/python/python3-dbus_1.2.16.bb')
-rw-r--r--external/poky/meta/recipes-devtools/python/python3-dbus_1.2.16.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/external/poky/meta/recipes-devtools/python/python3-dbus_1.2.16.bb b/external/poky/meta/recipes-devtools/python/python3-dbus_1.2.16.bb
new file mode 100644
index 00000000..e1700fa8
--- /dev/null
+++ b/external/poky/meta/recipes-devtools/python/python3-dbus_1.2.16.bb
@@ -0,0 +1,26 @@
+SUMMARY = "Python bindings for the DBus inter-process communication system"
+SECTION = "devel/python"
+HOMEPAGE = "http://www.freedesktop.org/Software/dbus"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b03240518994df6d8c974675675e5ca4"
+DEPENDS = "expat dbus glib-2.0 virtual/libintl"
+
+SRC_URI = "http://dbus.freedesktop.org/releases/dbus-python/dbus-python-${PV}.tar.gz"
+
+SRC_URI[md5sum] = "51a45c973d82bedff033a4b57d69d5d8"
+SRC_URI[sha256sum] = "11238f1d86c995d8aed2e22f04a1e3779f0d70e587caffeab4857f3c662ed5a4"
+
+S = "${WORKDIR}/dbus-python-${PV}"
+
+inherit distutils3-base autotools pkgconfig
+
+# documentation needs python3-sphinx, which is not in oe-core or meta-python for now
+# change to use PACKAGECONFIG when python3-sphinx is added to oe-core
+EXTRA_OECONF += "--disable-documentation"
+
+
+RDEPENDS_${PN} = "python3-io python3-logging python3-stringold python3-threading python3-xml"
+
+FILES_${PN}-dev += "${libdir}/pkgconfig"
+
+BBCLASSEXTEND = "native nativesdk"