summaryrefslogtreecommitdiffstats
path: root/external/poky/meta/recipes-devtools/python/python3-magic_0.4.15.bb
diff options
context:
space:
mode:
Diffstat (limited to 'external/poky/meta/recipes-devtools/python/python3-magic_0.4.15.bb')
-rw-r--r--external/poky/meta/recipes-devtools/python/python3-magic_0.4.15.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/external/poky/meta/recipes-devtools/python/python3-magic_0.4.15.bb b/external/poky/meta/recipes-devtools/python/python3-magic_0.4.15.bb
new file mode 100644
index 00000000..698016ba
--- /dev/null
+++ b/external/poky/meta/recipes-devtools/python/python3-magic_0.4.15.bb
@@ -0,0 +1,19 @@
+SUMMARY = "File type identification using libmagic"
+DESCRIPTION = "This module uses ctypes to access the libmagic file type \
+ identification library. It makes use of the local magic database and supports \
+ both textual and MIME-type output."
+HOMEPAGE = "http://github.com/ahupp/python-magic"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=16a934f165e8c3245f241e77d401bb88"
+
+PYPI_PACKAGE = "python-magic"
+
+inherit pypi setuptools3
+
+SRC_URI[md5sum] = "e384c95a47218f66c6501cd6dd45ff59"
+SRC_URI[sha256sum] = "f3765c0f582d2dfc72c15f3b5a82aecfae9498bd29ca840d72f37d7bd38bfcd5"
+
+RDEPENDS_${PN} += "file"
+
+BBCLASSEXTEND = "native"