summaryrefslogtreecommitdiffstats
path: root/external/poky/meta/recipes-extended/ethtool/ethtool_5.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'external/poky/meta/recipes-extended/ethtool/ethtool_5.4.bb')
-rw-r--r--external/poky/meta/recipes-extended/ethtool/ethtool_5.4.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/external/poky/meta/recipes-extended/ethtool/ethtool_5.4.bb b/external/poky/meta/recipes-extended/ethtool/ethtool_5.4.bb
new file mode 100644
index 00000000..d6eafaa8
--- /dev/null
+++ b/external/poky/meta/recipes-extended/ethtool/ethtool_5.4.bb
@@ -0,0 +1,33 @@
+SUMMARY = "Display or change ethernet card settings"
+DESCRIPTION = "A small utility for examining and tuning the settings of your ethernet-based network interfaces."
+HOMEPAGE = "http://www.kernel.org/pub/software/network/ethtool/"
+SECTION = "console/network"
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
+ file://ethtool.c;beginline=4;endline=17;md5=c19b30548c582577fc6b443626fc1216"
+
+SRC_URI = "${KERNELORG_MIRROR}/software/network/ethtool/ethtool-${PV}.tar.gz \
+ file://run-ptest \
+ file://avoid_parallel_tests.patch \
+ "
+
+SRC_URI[md5sum] = "fbb24aa414ab9a11ff66d351b5b8493b"
+SRC_URI[sha256sum] = "0b25a46b61bc6e26f56dcb973fc28acea159e2c32c9d6da42c0fa8d1a6339829"
+
+UPSTREAM_CHECK_URI = "https://www.kernel.org/pub/software/network/ethtool/"
+
+inherit autotools ptest bash-completion
+
+RDEPENDS_${PN}-ptest += "make"
+
+do_compile_ptest() {
+ oe_runmake buildtest-TESTS
+}
+
+do_install_ptest () {
+ cp ${B}/Makefile ${D}${PTEST_PATH}
+ install ${B}/test-cmdline ${D}${PTEST_PATH}
+ install ${B}/test-features ${D}${PTEST_PATH}
+ install ${B}/ethtool ${D}${PTEST_PATH}/ethtool
+ sed -i 's/^Makefile/_Makefile/' ${D}${PTEST_PATH}/Makefile
+}