summaryrefslogtreecommitdiffstats
path: root/external/poky/meta/recipes-extended/stress-ng/stress-ng_0.11.01.bb
diff options
context:
space:
mode:
Diffstat (limited to 'external/poky/meta/recipes-extended/stress-ng/stress-ng_0.11.01.bb')
-rw-r--r--external/poky/meta/recipes-extended/stress-ng/stress-ng_0.11.01.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/external/poky/meta/recipes-extended/stress-ng/stress-ng_0.11.01.bb b/external/poky/meta/recipes-extended/stress-ng/stress-ng_0.11.01.bb
new file mode 100644
index 00000000..3486be1b
--- /dev/null
+++ b/external/poky/meta/recipes-extended/stress-ng/stress-ng_0.11.01.bb
@@ -0,0 +1,25 @@
+SUMMARY = "System load testing utility"
+DESCRIPTION = "Deliberately simple workload generator for POSIX systems. It \
+imposes a configurable amount of CPU, memory, I/O, and disk stress on the system."
+HOMEPAGE = "https://kernel.ubuntu.com/~cking/stress-ng/"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+
+SRC_URI = "https://kernel.ubuntu.com/~cking/tarballs/${BPN}/${BP}.tar.xz \
+ file://0001-Do-not-preserve-ownership-when-installing-example-jo.patch \
+ "
+SRC_URI[md5sum] = "a558fc7fb9d0a851afe6de09080b5401"
+SRC_URI[sha256sum] = "9fe19548c87aa1a1b9b2be3b359ec2621b88bcb16998b77527549a7736f65494"
+
+DEPENDS = "coreutils-native"
+
+PROVIDES = "stress"
+RPROVIDES_${PN} = "stress"
+RREPLACES_${PN} = "stress"
+RCONFLICTS_${PN} = "stress"
+
+inherit bash-completion
+
+do_install() {
+ oe_runmake DESTDIR=${D} install
+}