summaryrefslogtreecommitdiffstats
path: root/external/poky/meta/recipes-support/boost/bjam-native_1.72.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'external/poky/meta/recipes-support/boost/bjam-native_1.72.0.bb')
-rw-r--r--external/poky/meta/recipes-support/boost/bjam-native_1.72.0.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/external/poky/meta/recipes-support/boost/bjam-native_1.72.0.bb b/external/poky/meta/recipes-support/boost/bjam-native_1.72.0.bb
new file mode 100644
index 00000000..d843eb03
--- /dev/null
+++ b/external/poky/meta/recipes-support/boost/bjam-native_1.72.0.bb
@@ -0,0 +1,20 @@
+require boost-${PV}.inc
+
+SUMMARY = "Portable Boost.Jam build tool for boost"
+SECTION = "devel"
+
+inherit native
+
+SRC_URI += "file://0001-Build-debug-version-of-bjam.patch \
+ file://0001-build.sh-use-DNDEBUG-also-in-debug-builds.patch \
+ "
+
+do_compile() {
+ ./bootstrap.sh --with-toolset=gcc
+}
+
+do_install() {
+ install -d ${D}${bindir}/
+ # install unstripped version for bjam
+ install -c -m 755 b2 ${D}${bindir}/bjam
+}