summaryrefslogtreecommitdiffstats
path: root/external/poky/meta/recipes-support/p11-kit/p11-kit_0.23.20.bb
diff options
context:
space:
mode:
Diffstat (limited to 'external/poky/meta/recipes-support/p11-kit/p11-kit_0.23.20.bb')
-rw-r--r--external/poky/meta/recipes-support/p11-kit/p11-kit_0.23.20.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/external/poky/meta/recipes-support/p11-kit/p11-kit_0.23.20.bb b/external/poky/meta/recipes-support/p11-kit/p11-kit_0.23.20.bb
new file mode 100644
index 00000000..4ba93f99
--- /dev/null
+++ b/external/poky/meta/recipes-support/p11-kit/p11-kit_0.23.20.bb
@@ -0,0 +1,29 @@
+SUMMARY = "Provides a way to load and enumerate PKCS#11 modules"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://COPYING;md5=02933887f609807fbb57aa4237d14a50"
+
+inherit meson gettext pkgconfig gtk-doc bash-completion
+
+DEPENDS = "libtasn1 libtasn1-native libffi"
+
+DEPENDS_append = "${@' glib-2.0' if d.getVar('GTKDOC_ENABLED') == 'True' else ''}"
+
+SRC_URI = "git://github.com/p11-glue/p11-kit"
+SRCREV = "762cdaa2cd5c5ec09cc844f9a6bdc551c7f6c8ed"
+S = "${WORKDIR}/git"
+
+PACKAGECONFIG ??= ""
+PACKAGECONFIG[trust-paths] = "-Dtrust_paths=/etc/ssl/certs/ca-certificates.crt,,,ca-certificates"
+
+GTKDOC_MESON_OPTION = 'gtk_doc'
+
+FILES_${PN} += " \
+ ${libdir}/p11-kit-proxy.so \
+ ${libdir}/pkcs11/*.so \
+ ${libdir}/pkcs11/*.la \
+ ${systemd_user_unitdir}/*"
+
+# PN contains p11-kit-proxy.so, a symlink to a loadable module
+INSANE_SKIP_${PN} = "dev-so"
+
+BBCLASSEXTEND = "nativesdk"