summaryrefslogtreecommitdiffstats
path: root/external/poky/meta/recipes-support/serf/serf_1.3.9.bb
diff options
context:
space:
mode:
Diffstat (limited to 'external/poky/meta/recipes-support/serf/serf_1.3.9.bb')
-rw-r--r--external/poky/meta/recipes-support/serf/serf_1.3.9.bb26
1 files changed, 14 insertions, 12 deletions
diff --git a/external/poky/meta/recipes-support/serf/serf_1.3.9.bb b/external/poky/meta/recipes-support/serf/serf_1.3.9.bb
index 65a8114b..6a27f121 100644
--- a/external/poky/meta/recipes-support/serf/serf_1.3.9.bb
+++ b/external/poky/meta/recipes-support/serf/serf_1.3.9.bb
@@ -6,6 +6,7 @@ SRC_URI = "${APACHE_MIRROR}/${BPN}/${BPN}-${PV}.tar.bz2 \
file://0002-SConstruct-Fix-path-quoting-for-.def-generator.patch \
file://0003-gen_def.patch \
file://0004-Follow-up-to-r1811083-fix-building-with-scons-3.0.0-.patch \
+ file://SConstruct.stop.creating.directories.without.sandbox-install.prefix.patch \
"
SRC_URI[md5sum] = "370a6340ff20366ab088012cd13f2b57"
@@ -14,18 +15,19 @@ SRC_URI[sha256sum] = "549c2d21c577a8a9c0450facb5cca809f26591f048e466552240947bdf
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
-DEPENDS = "python-scons-native openssl apr apr-util util-linux expat"
+inherit scons
-do_compile() {
- ${STAGING_BINDIR_NATIVE}/scons ${PARALLEL_MAKE} PREFIX=${prefix} \
- CC="${CC}" \
- APR=`which apr-1-config` APU=`which apu-1-config` \
- CFLAGS="${CFLAGS}" LINKFLAGS="${LDFLAGS}" \
- OPENSSL="${STAGING_EXECPREFIXDIR}"
-}
+DEPENDS += " openssl apr apr-util util-linux expat"
-do_install() {
- ${STAGING_BINDIR_NATIVE}/scons PREFIX=${D}${prefix} LIBDIR=${D}${libdir} install
-}
+EXTRA_OESCONS = " \
+ LIBDIR=${libdir} \
+ --install-sandbox=${D} \
+ CC="${CC}" \
+ CFLAGS="${CFLAGS}" \
+ LINKFLAGS="${LDFLAGS}" \
+ APR=`which apr-1-config` \
+ APU=`which apu-1-config` \
+ OPENSSL="${STAGING_EXECPREFIXDIR}" \
+ "
-BBCLASSEXTEND = "native"
+BBCLASSEXTEND = "native nativesdk"