summaryrefslogtreecommitdiffstats
path: root/meta-agl-demo/recipes-demo-hmi/homescreen/homescreen_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-agl-demo/recipes-demo-hmi/homescreen/homescreen_git.bb')
-rw-r--r--meta-agl-demo/recipes-demo-hmi/homescreen/homescreen_git.bb14
1 files changed, 10 insertions, 4 deletions
diff --git a/meta-agl-demo/recipes-demo-hmi/homescreen/homescreen_git.bb b/meta-agl-demo/recipes-demo-hmi/homescreen/homescreen_git.bb
index 984e5153..bfdf06e7 100644
--- a/meta-agl-demo/recipes-demo-hmi/homescreen/homescreen_git.bb
+++ b/meta-agl-demo/recipes-demo-hmi/homescreen/homescreen_git.bb
@@ -3,19 +3,21 @@ DESCRIPTION = "AGL Home Screen Application build with recipe method"
HOMEPAGE = "http://docs.automotivelinux.org"
LICENSE = "Apache-2.0"
SECTION = "apps"
-LIC_FILES_CHKSUM = "file://homescreen/LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
DEPENDS = "\
qtbase \
qtdeclarative \
qtquickcontrols2 \
agl-service-homescreen \
- agl-service-windowmanager \
agl-service-weather \
libqtappfw \
- qlibwindowmanager \
libhomescreen \
- libafb-helpers-qt \
+ libafb-helpers-qt \
+ wayland-native \
+ wayland \
+ qtwayland \
+ qtwayland-native \
"
inherit qmake5 systemd pkgconfig aglwgt
@@ -29,3 +31,7 @@ S = "${WORKDIR}/git/"
PATH_prepend = "${STAGING_DIR_NATIVE}${OE_QMAKE_PATH_QT_BINS}:"
OE_QMAKE_CXXFLAGS_append = " ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', '' , '-DQT_NO_DEBUG_OUTPUT', d)}"
+
+RDEPENDS_${PN} += " \
+ libqtappfw \
+"