summaryrefslogtreecommitdiffstats
path: root/recipes-demo-hmi/cluster-windowmanager-conf/cluster-windowmanager-conf_1.0.bb
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2018-12-07 16:46:37 -0500
committerScott Murray <scott.murray@konsulko.com>2018-12-10 13:50:24 -0500
commit251fb524e791d40cb7a7e1581649e63da9da3b08 (patch)
tree1c39d533cb1a7318b83146a0e43e563654f0f6fb /recipes-demo-hmi/cluster-windowmanager-conf/cluster-windowmanager-conf_1.0.bb
parent7ea4459ecd58198e4932db3f41fadecf0024325c (diff)
Define instrument cluster demo platform. This layer is similar to meta-agl-demo, except it defines a small platform for the instrument cluster demo, based on the agl-profile-cluster-qt5 profile. There is a "agl-cluster-demo" feature defined to enable building the platform. At the moment, only qemux86-64 and Minnowboard turbot versions have been built and tested. Other architectures should be feasible, but the agl-cluster-demo-receiver application needs some further development to support non-Intel platforms, as currently it is using the vaapisink gstreamer plug-in. Change-Id: I217608a1ecc9678d5d55a95c65f3ab6f10d5b54f Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Diffstat (limited to 'recipes-demo-hmi/cluster-windowmanager-conf/cluster-windowmanager-conf_1.0.bb')
-rw-r--r--recipes-demo-hmi/cluster-windowmanager-conf/cluster-windowmanager-conf_1.0.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes-demo-hmi/cluster-windowmanager-conf/cluster-windowmanager-conf_1.0.bb b/recipes-demo-hmi/cluster-windowmanager-conf/cluster-windowmanager-conf_1.0.bb
new file mode 100644
index 0000000..0cef85c
--- /dev/null
+++ b/recipes-demo-hmi/cluster-windowmanager-conf/cluster-windowmanager-conf_1.0.bb
@@ -0,0 +1,19 @@
+SUMMARY = "Cluster demo windowmanager configuration"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+
+SRC_URI = "file://layers.json \
+ file://areas.db \
+ file://roles.db \
+"
+
+do_compile[noexec] = "1"
+
+do_install() {
+ install -d ${D}${sysconfdir}/xdg/windowmanager
+ install -m 0644 ${WORKDIR}/layers.json ${D}${sysconfdir}/xdg/windowmanager/layers.json
+ install -m 0644 ${WORKDIR}/areas.db ${D}${sysconfdir}/xdg/windowmanager/areas.db
+ install -m 0644 ${WORKDIR}/roles.db ${D}${sysconfdir}/xdg/windowmanager/roles.db
+}
+
+#FILES_${PN} += "${sysconfdir}/*"