summaryrefslogtreecommitdiffstats
path: root/recipes-demo-hmi/cluster-windowmanager-conf/cluster-windowmanager-conf_1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-demo-hmi/cluster-windowmanager-conf/cluster-windowmanager-conf_1.0.bb')
-rw-r--r--recipes-demo-hmi/cluster-windowmanager-conf/cluster-windowmanager-conf_1.0.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes-demo-hmi/cluster-windowmanager-conf/cluster-windowmanager-conf_1.0.bb b/recipes-demo-hmi/cluster-windowmanager-conf/cluster-windowmanager-conf_1.0.bb
new file mode 100644
index 0000000..0cef85c
--- /dev/null
+++ b/recipes-demo-hmi/cluster-windowmanager-conf/cluster-windowmanager-conf_1.0.bb
@@ -0,0 +1,19 @@
+SUMMARY = "Cluster demo windowmanager configuration"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+
+SRC_URI = "file://layers.json \
+ file://areas.db \
+ file://roles.db \
+"
+
+do_compile[noexec] = "1"
+
+do_install() {
+ install -d ${D}${sysconfdir}/xdg/windowmanager
+ install -m 0644 ${WORKDIR}/layers.json ${D}${sysconfdir}/xdg/windowmanager/layers.json
+ install -m 0644 ${WORKDIR}/areas.db ${D}${sysconfdir}/xdg/windowmanager/areas.db
+ install -m 0644 ${WORKDIR}/roles.db ${D}${sysconfdir}/xdg/windowmanager/roles.db
+}
+
+#FILES_${PN} += "${sysconfdir}/*"