summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHritik Chouhan <hritikc3961@gmail.com>2022-10-05 21:18:43 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2022-10-08 21:50:47 +0000
commit0b9ee96eac781f044fef295ea34c7630068c3d45 (patch)
tree1a883f5e2b287d6b4d0981b7ab4716eaeb526b46
parentf9200e31a017719f58e2cc95b6f54fa1e18d7654 (diff)
Change SRC_URI and SRCREV for ivi-demo-flutter-apps
- Change SRC_URI to use the app repository on gerrit. - Renamed recipes file name. Bug-AGL: SPEC-4560 Change-Id: I2887e568e6a466836d68866ace0766c7ed7949d9 Signed-off-by: Hritik Chouhan <hritikc3961@gmail.com>
-rw-r--r--recipes-demo/flutter-dashboard/flutter-dashboard_git.bb (renamed from recipes-demo/flutter-dashboard/flutter-app-dashboard_git.bb)6
-rw-r--r--recipes-demo/flutter-hvac/files/HVAC_config.yaml (renamed from recipes-demo/flutter-hvac/files/hvac_config.yaml)0
-rw-r--r--recipes-demo/flutter-hvac/flutter-hvac_git.bb (renamed from recipes-demo/flutter-hvac/flutter-app-hvac_git.bb)10
-rw-r--r--recipes-demo/flutter-mediaplayer/flutter-mediaplayer_git.bb (renamed from recipes-demo/flutter-mediaplayer/flutter-app-mediaplayer_git.bb)6
-rw-r--r--recipes-demo/flutter-nav/flutter-nav_git.bb (renamed from recipes-demo/flutter-nav/flutter-app-nav_git.bb)6
-rw-r--r--recipes-platform/packagegroups/packagegroup-agl-demo-platform-flutter.bb8
6 files changed, 18 insertions, 18 deletions
diff --git a/recipes-demo/flutter-dashboard/flutter-app-dashboard_git.bb b/recipes-demo/flutter-dashboard/flutter-dashboard_git.bb
index 71d988db..d44b30c9 100644
--- a/recipes-demo/flutter-dashboard/flutter-app-dashboard_git.bb
+++ b/recipes-demo/flutter-dashboard/flutter-dashboard_git.bb
@@ -1,7 +1,7 @@
SUMMARY = "Flutter Dashboard"
DESCRIPTION = "A Flutter based IVI Dashboard Application for automotive grade Linux."
-HOMEPAGE = "https://github.com/hritik-chouhan/dashboard_for_recipe"
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/apps/flutter-dashboard"
BUGTRACKER = "https://github.com/hritik-chouhan/dashboard_for_recipe/issues"
@@ -11,11 +11,11 @@ LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://License.md;md5=f712ede8d4f845976061925d1416fc40"
-SRC_URI = "git://github.com/hritik-chouhan/dashboard_for_recipe.git;protocol=https;branch=main \
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/flutter-dashboard;protocol=https;branch=${AGL_BRANCH} \
file://dashboard_config.yaml \
"
-SRCREV = "5b0e5cdc3ba8b00a7e53b46e8b3e656cd09822bb"
+SRCREV = "10945b8056eb2b228c156918a3505882a49a79b8"
S = "${WORKDIR}/git"
diff --git a/recipes-demo/flutter-hvac/files/hvac_config.yaml b/recipes-demo/flutter-hvac/files/HVAC_config.yaml
index 6824c6b7..6824c6b7 100644
--- a/recipes-demo/flutter-hvac/files/hvac_config.yaml
+++ b/recipes-demo/flutter-hvac/files/HVAC_config.yaml
diff --git a/recipes-demo/flutter-hvac/flutter-app-hvac_git.bb b/recipes-demo/flutter-hvac/flutter-hvac_git.bb
index a4038f13..a2062411 100644
--- a/recipes-demo/flutter-hvac/flutter-app-hvac_git.bb
+++ b/recipes-demo/flutter-hvac/flutter-hvac_git.bb
@@ -1,7 +1,7 @@
SUMMARY = "Flutter HVAC"
DESCRIPTION = "A Flutter based IVI Dashboard Application for automotive grade Linux."
-HOMEPAGE = "https://github.com/hritik-chouhan/HVAC_dashboard"
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/apps/flutter-hvac"
BUGTRACKER = "https://github.com/hritik-chouhan/HVAC_dashboard/issues"
@@ -11,11 +11,11 @@ LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://License.md;md5=f712ede8d4f845976061925d1416fc40"
-SRC_URI = "git://github.com/hritik-chouhan/HVAC_dashboard.git;protocol=https;branch=main \
- file://hvac_config.yaml \
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/flutter-hvac;protocol=https;branch=${AGL_BRANCH} \
+ file://HVAC_config.yaml \
"
-SRCREV = "892f09a82dd852b66416598c9ec47b3230c5d56c"
+SRCREV = "5559cdb261cfd3e69daa2349906f071dc2491c0d"
S = "${WORKDIR}/git"
inherit agl-app flutter-app
@@ -34,7 +34,7 @@ AGL_APP_NAME = "Flutter Hvac"
do_install:append() {
install -d ${D}${sysconfdir}/xdg/AGL
- install -m 0644 ${WORKDIR}/hvac_config.yaml ${D}${sysconfdir}/xdg/AGL/
+ install -m 0644 ${WORKDIR}/HVAC_config.yaml ${D}${sysconfdir}/xdg/AGL/
}
FILES:${PN} += "${sysconfdir}/xdg/AGL"
diff --git a/recipes-demo/flutter-mediaplayer/flutter-app-mediaplayer_git.bb b/recipes-demo/flutter-mediaplayer/flutter-mediaplayer_git.bb
index ee016825..cfcfa265 100644
--- a/recipes-demo/flutter-mediaplayer/flutter-app-mediaplayer_git.bb
+++ b/recipes-demo/flutter-mediaplayer/flutter-mediaplayer_git.bb
@@ -1,7 +1,7 @@
SUMMARY = "Flutter MediaPlayer app for IVI"
DESCRIPTION = "A Flutter based IVI Dashboard Application for automotive grade Linux"
-HOMEPAGE = "https://github.com/hritik-chouhan/musicplayer"
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/apps/flutter-mediaplayer"
BUGTRACKER = "https://github.com/hritik-chouhan/musicplayer/issues"
@@ -11,8 +11,8 @@ LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://License.md;md5=f712ede8d4f845976061925d1416fc40"
-SRC_URI = "git://github.com/hritik-chouhan/musicplayer.git;protocol=https;branch=main"
-SRCREV = "45f9425552ec08a8706953c41aa25b0fc1a6fb57"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/flutter-mediaplayer;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "735de5a38ea937ee13157f6ac594053ddb8b027b"
S = "${WORKDIR}/git"
inherit agl-app flutter-app
diff --git a/recipes-demo/flutter-nav/flutter-app-nav_git.bb b/recipes-demo/flutter-nav/flutter-nav_git.bb
index 3bc2f427..0e8b8ac7 100644
--- a/recipes-demo/flutter-nav/flutter-app-nav_git.bb
+++ b/recipes-demo/flutter-nav/flutter-nav_git.bb
@@ -1,7 +1,7 @@
SUMMARY = "Flutter Navigation app"
DESCRIPTION = "A Flutter based IVI Dashboard Application for automotive grade Linux."
-HOMEPAGE = "https://github.com/hritik-chouhan/nav-app"
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/apps/flutter-navigation"
BUGTRACKER = "https://github.com/hritik-chouhan/nav-app/issues"
@@ -11,10 +11,10 @@ LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://License.md;md5=f712ede8d4f845976061925d1416fc40"
-SRC_URI = "git://github.com/hritik-chouhan/nav-app.git;protocol=https;branch=main \
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/flutter-navigation;protocol=https;branch=${AGL_BRANCH} \
file://nav_config.yaml \
"
-SRCREV = "a6619ac0439f6dec728b9a3a094f1371ee00ce76"
+SRCREV = "53164c0441db946b4293f483a28b524ecdc91e30"
S = "${WORKDIR}/git"
MAPBOX_API_KEY ??= "YOU_NEED_TO_SET_IT_IN_LOCAL_CONF"
diff --git a/recipes-platform/packagegroups/packagegroup-agl-demo-platform-flutter.bb b/recipes-platform/packagegroups/packagegroup-agl-demo-platform-flutter.bb
index c40d0f69..2ab68823 100644
--- a/recipes-platform/packagegroups/packagegroup-agl-demo-platform-flutter.bb
+++ b/recipes-platform/packagegroups/packagegroup-agl-demo-platform-flutter.bb
@@ -20,10 +20,10 @@ RDEPENDS:${PN} += "\
AGL_APPS = " \
hvac \
dashboard \
- flutter-app-dashboard \
- flutter-app-hvac \
- flutter-app-nav \
- flutter-app-mediaplayer \
+ flutter-dashboard \
+ flutter-hvac \
+ flutter-nav \
+ flutter-mediaplayer \
"
RDEPENDS:${PN}:append = " \