summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2019-06-25 19:09:57 -0400
committerScott Murray <scott.murray@konsulko.com>2019-06-25 19:22:49 -0400
commit0e4f8059a575a47a2e9b84614762306f5a27cfcb (patch)
tree1fb332ea9a1185d65638e8e92bb15ece13423cb4
parenta68964385411646ca709e4dee9f916969663f691 (diff)
poiapp-api-key: switch to allarch class
Switch from setting PACKAGE_ARCH to inheriting the allarch class in the poiapp-api-key recipe. This fixes a failure when building an image with the agl-demo-preload feature that seems due to a change between rocko and thud. Bug-AGL: SPEC-2567 Change-Id: I0ad6289897261ece5971cdea4888c6cd13793643 Signed-off-by: Scott Murray <scott.murray@konsulko.com>
-rw-r--r--[-rwxr-xr-x]recipes-demo-hmi/navigation/poiapp-api-key_1.0.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/recipes-demo-hmi/navigation/poiapp-api-key_1.0.bb b/recipes-demo-hmi/navigation/poiapp-api-key_1.0.bb
index 4d53fdbf..d353d7dd 100755..100644
--- a/recipes-demo-hmi/navigation/poiapp-api-key_1.0.bb
+++ b/recipes-demo-hmi/navigation/poiapp-api-key_1.0.bb
@@ -5,6 +5,8 @@ SECTION = "apps"
LICENSE = "Proprietary"
LIC_FILES_CHKSUM="file://${COMMON_LICENSE_DIR}/Proprietary;md5=0557f9d92cf58f2ccdd50f62f8ac0b28"
+inherit allarch
+
do_fetch[noexec] = "1"
do_unpack[noexec] = "1"
do_compile[noexec] = "1"
@@ -17,5 +19,3 @@ do_install () {
echo "${POIAPP_CLIENT_ID}" > ${D}${sysconfdir}/poikey
echo "${POIAPP_API_KEY}" >> ${D}${sysconfdir}/poikey
}
-
-PACKAGE_ARCH = "all"