summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLorenzo Tilve <ltilve@igalia.com>2020-02-06 19:03:29 +0100
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2020-02-14 15:18:38 +0000
commit923ce5e1561f23741dc37065993f6c38aca35e9f (patch)
tree8ba7ebac8d1f6ac63c84937ba86b2da9610177cb
parent4f1fbee15a1029056a9ac3e2a1172f15c7836718 (diff)
html5-dashboard: create recipe and add to html5 demoicefish_9.0.0icefish/9.0.09.0.0
Bug-AGL: SPEC-3151 Change-Id: Iee5fcba63de56f7d326a9015902f63e4d48632bf Signed-off-by: Lorenzo Tilve <ltilve@igalia.com> (cherry picked from commit 2e014bfbd0757f2e35559543ba78d95cbc88b2c5)
-rw-r--r--recipes-demo-hmi/html5-dashboard/html5-dashboard_git.bb25
-rw-r--r--recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb1
2 files changed, 26 insertions, 0 deletions
diff --git a/recipes-demo-hmi/html5-dashboard/html5-dashboard_git.bb b/recipes-demo-hmi/html5-dashboard/html5-dashboard_git.bb
new file mode 100644
index 00000000..534bd2d3
--- /dev/null
+++ b/recipes-demo-hmi/html5-dashboard/html5-dashboard_git.bb
@@ -0,0 +1,25 @@
+SUMMARY = "AGL HTML5 dashboard Application"
+HOMEPAGE = "https://git.automotivelinux.org/apps/html5-dashboard/"
+SECTION = "apps"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+PV = "1.0+git${SRCPV}"
+S = "${WORKDIR}/git/"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/html5-dashboard;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "${AGL_APP_REVISION}"
+
+DEPENDS += " nodejs-native"
+
+inherit aglwgt
+
+do_configure() {
+ cd ${B}
+ npm install
+}
+
+do_aglwgt_package() {
+ cd ${B}
+ npm run build
+}
diff --git a/recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb b/recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb
index a9637228..6ec717bd 100644
--- a/recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb
+++ b/recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb
@@ -24,6 +24,7 @@ AGL_APPS = " \
html5-settings \
html5-mixer \
html5-mediaplayer \
+ html5-dashboard \
"
RDEPENDS_${PN}_append = " \