summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatt Ranostay <matt.ranostay@konsulko.com>2018-04-04 18:56:06 -0700
committerMatt Ranostay <matt.ranostay@konsulko.com>2018-04-04 19:31:53 -0700
commit9cdb55a111f2a4cf55d3b9c755e65a78b56d88a5 (patch)
tree4e710be5fd93dbcbe0acc128d7c0362a3a021333
parent155ab788720321b2cbfafb2cd78787265034ec47 (diff)
mediaplayer: update dependencies for recipe
Update dependecies as follows: * remove agl-service-mediascanner as RDEPENDS * remove sqlite from DEPENDS * add libqtappfw and qtwebsockets to DEPENDS * add previously missing agl-service-bluetooth, and agl-service-mediaplayer to RDEPENDS Bug-AGL: SPEC-1375 Change-Id: I10213180e174da9df9b513d8519c8ce5b429896e Signed-off-by: Matt Ranostay <matt.ranostay@konsulko.com>
-rw-r--r--recipes-demo-hmi/mediaplayer/mediaplayer_git.bb9
1 files changed, 6 insertions, 3 deletions
diff --git a/recipes-demo-hmi/mediaplayer/mediaplayer_git.bb b/recipes-demo-hmi/mediaplayer/mediaplayer_git.bb
index e99eb5bd..b2524090 100644
--- a/recipes-demo-hmi/mediaplayer/mediaplayer_git.bb
+++ b/recipes-demo-hmi/mediaplayer/mediaplayer_git.bb
@@ -13,9 +13,10 @@ PV = "1.0+git${SRCPV}"
S = "${WORKDIR}/git"
# build-time dependencies
-DEPENDS += "sqlite3 \
- qtquickcontrols2 \
+DEPENDS += "qtquickcontrols2 \
qtmultimedia \
+ qtwebsockets \
+ libqtappfw \
virtual/libhomescreen \
qlibwindowmanager \
"
@@ -24,4 +25,6 @@ inherit qmake5 aglwgt
RDEPENDS_${PN} += "qtmultimedia \
qtmultimedia-qmlplugins \
- agl-service-mediascanner"
+ agl-service-mediaplayer \
+ agl-service-bluetooth \
+"