summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoel Winarske <joel.winarske@gmail.com>2024-09-06 08:02:09 -0700
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2024-09-09 15:28:46 +0000
commite744a9e1d2399a133171e45c5819bf6051989ad4 (patch)
treec3736cc4900c64ccdb83954ea05d32ef5cc2e2b8
parentdb5447e035014952483cde78ea580fafd5201896 (diff)
flutter SDK 3.24.2
-update flutter-ics-homescreen and flutter-instrument-cluster Change-Id: I2a12cf07f1c5ec8dc839b9f1b868b62069308be1 Signed-off-by: Joel Winarske <joel.winarske@gmail.com> (Updated flutter-cluster-dashboard systemd unit file) Signed-off-by: Scott Murray <scott.murray@konsulko.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl-demo/+/30257 Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Tested-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
-rw-r--r--recipes-demo/flutter-cluster-dashboard/files/flutter-cluster-dashboard.service2
-rw-r--r--recipes-demo/flutter-cluster-dashboard/files/flutter_cluster_dashboard_on_bg.json10
-rw-r--r--recipes-demo/flutter-cluster-dashboard/files/flutter_cluster_dashboard_on_bg.toml5
-rw-r--r--recipes-demo/flutter-cluster-dashboard/flutter-cluster-dashboard_git.bb13
-rw-r--r--recipes-demo/flutter-ics-homescreen/files/flutter-ics-homescreen.json10
-rw-r--r--recipes-demo/flutter-ics-homescreen/files/flutter-ics-homescreen.service2
-rw-r--r--recipes-demo/flutter-ics-homescreen/files/ics-homescreen.toml11
-rw-r--r--recipes-demo/flutter-ics-homescreen/flutter-ics-homescreen_git.bb15
8 files changed, 37 insertions, 31 deletions
diff --git a/recipes-demo/flutter-cluster-dashboard/files/flutter-cluster-dashboard.service b/recipes-demo/flutter-cluster-dashboard/files/flutter-cluster-dashboard.service
index 21082e7eb..83fe23508 100644
--- a/recipes-demo/flutter-cluster-dashboard/files/flutter-cluster-dashboard.service
+++ b/recipes-demo/flutter-cluster-dashboard/files/flutter-cluster-dashboard.service
@@ -7,7 +7,7 @@ User=agl-driver
EnvironmentFile=/etc/default/flutter
EnvironmentFile=-/etc/default/flutter-cluster-dashboard
Environment=XDG_RUNTIME_DIR=/run/user/1001/
-ExecStart=/usr/bin/flutter-auto --b=/usr/share/flutter/flutter_cluster_dashboard/${FLUTTER_VERSION}/${FLUTTER_RUNTIME} --j=/usr/share/flutter/flutter-cluster-dashboard.json
+ExecStart=/usr/bin/flutter-auto -b /usr/share/flutter/flutter_cluster_dashboard/${FLUTTER_VERSION}/${FLUTTER_RUNTIME}
Restart=on-failure
[Install]
diff --git a/recipes-demo/flutter-cluster-dashboard/files/flutter_cluster_dashboard_on_bg.json b/recipes-demo/flutter-cluster-dashboard/files/flutter_cluster_dashboard_on_bg.json
deleted file mode 100644
index c90e5e3ae..000000000
--- a/recipes-demo/flutter-cluster-dashboard/files/flutter_cluster_dashboard_on_bg.json
+++ /dev/null
@@ -1,10 +0,0 @@
-{
- "view": [
- {
- "window_type": "BG",
- "width": 1920,
- "height": 1080,
- "fullscreen": true
- }
- ]
-}
diff --git a/recipes-demo/flutter-cluster-dashboard/files/flutter_cluster_dashboard_on_bg.toml b/recipes-demo/flutter-cluster-dashboard/files/flutter_cluster_dashboard_on_bg.toml
new file mode 100644
index 000000000..cb78ab0cd
--- /dev/null
+++ b/recipes-demo/flutter-cluster-dashboard/files/flutter_cluster_dashboard_on_bg.toml
@@ -0,0 +1,5 @@
+[view]
+window_type = "BG"
+width = 1080
+height = 1920
+fullscreen = true
diff --git a/recipes-demo/flutter-cluster-dashboard/flutter-cluster-dashboard_git.bb b/recipes-demo/flutter-cluster-dashboard/flutter-cluster-dashboard_git.bb
index ad789d90d..e6aee7741 100644
--- a/recipes-demo/flutter-cluster-dashboard/flutter-cluster-dashboard_git.bb
+++ b/recipes-demo/flutter-cluster-dashboard/flutter-cluster-dashboard_git.bb
@@ -10,7 +10,7 @@ LIC_FILES_CHKSUM = "file://LICENSE.md;md5=0c52b0e4b5f0dbf57ea7d44bebb2e29d"
SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/flutter-instrument-cluster;protocol=https;branch=${AGL_BRANCH} \
file://flutter-cluster-dashboard.service \
- file://flutter_cluster_dashboard_on_bg.json \
+ file://flutter_cluster_dashboard_on_bg.toml \
file://cluster-dashboard.yaml \
file://cluster-dashboard.yaml.demo \
file://cluster-dashboard.yaml.gateway-demo \
@@ -21,7 +21,7 @@ SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/flutter-instrument-clust
"
PV = "1.0+git${SRCPV}"
-SRCREV = "4a6dd91a1e1c7821eae1668449885a8c04825071"
+SRCREV = "15093ee4880d535c65faed929801c2d79d1a212c"
S = "${WORKDIR}/git"
@@ -29,7 +29,7 @@ PUBSPEC_APPNAME = "flutter_cluster_dashboard"
inherit flutter-app update-alternatives systemd
-APP_CONFIG = "flutter_cluster_dashboard_on_bg.json"
+APP_CONFIG = "flutter_cluster_dashboard_on_bg.toml"
SYSTEMD_SERVICE:${PN} = "flutter-cluster-dashboard.service"
@@ -40,7 +40,12 @@ do_install:append() {
install -D -m 0644 ${WORKDIR}/kvm.conf ${D}${systemd_system_unitdir}/${BPN}.service.d/kvm.conf
- install -D -m 0644 ${WORKDIR}/${APP_CONFIG} ${D}${datadir}/flutter/${BPN}.json
+ # determine build type based on what flutter-engine installed.
+ for runtime_mode in ${FLUTTER_RUNTIME_MODES}
+ do
+ install -D -m 0644 ${WORKDIR}/${APP_CONFIG} \
+ ${D}${datadir}/flutter/${PUBSPEC_APPNAME}/${FLUTTER_SDK_VERSION}/${runtime_mode}/config.toml
+ done
install -d ${D}${sysconfdir}/xdg/AGL/cluster-dashboard
install -m 0644 ${WORKDIR}/cluster-dashboard.yaml ${D}${sysconfdir}/xdg/AGL/cluster-dashboard.yaml.default
diff --git a/recipes-demo/flutter-ics-homescreen/files/flutter-ics-homescreen.json b/recipes-demo/flutter-ics-homescreen/files/flutter-ics-homescreen.json
deleted file mode 100644
index 2817e5fed..000000000
--- a/recipes-demo/flutter-ics-homescreen/files/flutter-ics-homescreen.json
+++ /dev/null
@@ -1,10 +0,0 @@
-{
- "view" : [ {
- "window_type" : "BG",
- "width" : 1080,
- "height": 1920,
- "fullscreen": true,
- "window_activation_area" : { "x" : 0, "y" : 56, "width" : 1080, "height" : 1712 }
- }
- ]
-}
diff --git a/recipes-demo/flutter-ics-homescreen/files/flutter-ics-homescreen.service b/recipes-demo/flutter-ics-homescreen/files/flutter-ics-homescreen.service
index a61b4a1de..421f87cda 100644
--- a/recipes-demo/flutter-ics-homescreen/files/flutter-ics-homescreen.service
+++ b/recipes-demo/flutter-ics-homescreen/files/flutter-ics-homescreen.service
@@ -7,7 +7,7 @@ User=agl-driver
EnvironmentFile=/etc/default/flutter
EnvironmentFile=-/etc/default/flutter-ics-homescreen
Environment=XDG_RUNTIME_DIR=/run/user/1001/
-ExecStart=/usr/bin/flutter-auto --b=/usr/share/flutter/flutter_ics_homescreen/${FLUTTER_VERSION}/${FLUTTER_RUNTIME} --j=/usr/share/flutter/flutter-ics-homescreen.json --xdg-shell-app-id=homescreen
+ExecStart=/usr/bin/flutter-auto -b /usr/share/flutter/flutter_ics_homescreen/${FLUTTER_VERSION}/${FLUTTER_RUNTIME} --xdg-shell-app-id homescreen
Restart=on-failure
[Install]
diff --git a/recipes-demo/flutter-ics-homescreen/files/ics-homescreen.toml b/recipes-demo/flutter-ics-homescreen/files/ics-homescreen.toml
new file mode 100644
index 000000000..e5cb7f999
--- /dev/null
+++ b/recipes-demo/flutter-ics-homescreen/files/ics-homescreen.toml
@@ -0,0 +1,11 @@
+[view]
+window_type = "BG"
+width = 1080
+height = 1920
+fullscreen = true
+
+[window_activation_area]
+x = 0
+y = 56
+width = 1080
+height = 1712
diff --git a/recipes-demo/flutter-ics-homescreen/flutter-ics-homescreen_git.bb b/recipes-demo/flutter-ics-homescreen/flutter-ics-homescreen_git.bb
index c911547c0..85e93d043 100644
--- a/recipes-demo/flutter-ics-homescreen/flutter-ics-homescreen_git.bb
+++ b/recipes-demo/flutter-ics-homescreen/flutter-ics-homescreen_git.bb
@@ -7,7 +7,7 @@ LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/flutter-ics-homescreen;protocol=https;branch=${AGL_BRANCH} \
- file://flutter-ics-homescreen.json \
+ file://ics-homescreen.toml \
file://flutter-ics-homescreen.service \
file://ics-homescreen.yaml \
file://ics-homescreen.yaml.gateway-demo \
@@ -17,16 +17,15 @@ SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/flutter-ics-homescreen;p
file://radio-presets.yaml \
file://kvm.conf \
"
-SRCREV = "3ef28eeae6e3336232ab13d0d934aa82892dfe74"
+SRCREV = "d3ea8d7fa4518c258fca3c825ee895487fcaa8ec"
S = "${WORKDIR}/git"
PUBSPEC_APPNAME = "flutter_ics_homescreen"
-FLUTTER_BUILD_ARGS = "bundle -v"
inherit flutter-app systemd update-alternatives
-APP_CONFIG = "${BPN}.json"
+APP_CONFIG = "ics-homescreen.toml"
SYSTEMD_SERVICE:${PN} = "flutter-ics-homescreen.service"
@@ -42,7 +41,13 @@ do_install:append() {
install -D -m 0644 ${WORKDIR}/kvm.conf ${D}${systemd_system_unitdir}/${BPN}.service.d/kvm.conf
- install -D -m 0644 ${WORKDIR}/${APP_CONFIG} ${D}${datadir}/flutter/${BPN}.json
+ # determine build type based on what flutter-engine installed.
+ for runtime_mode in ${FLUTTER_RUNTIME_MODES}
+ do
+ install -D -m 0644 ${WORKDIR}/${APP_CONFIG} \
+ ${D}${datadir}/flutter/${PUBSPEC_APPNAME}/${FLUTTER_SDK_VERSION}/${runtime_mode}/config.toml
+ done
+
# VIS authorization token file for KUKSA.val should ideally not
# be readable by other users, but currently that's not doable