summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarius Vlad <marius.vlad@collabora.com>2022-03-11 17:32:27 +0200
committerMarius Vlad <marius.vlad@collabora.com>2022-03-11 17:35:03 +0200
commitfdadccd28a38eb9aae90f2871fbd901ac73613c2 (patch)
tree30bc5e472aeb5334d198f66b79db563ae2d3ffbb
parentb44514b059fd751138da7453ea4c138572fdab23 (diff)
html5-launcher_git: Remove autobuild script builds
Bug-AGL: SPEC-4295 Signed-off-by: Marius Vlad <marius.vlad@collabora.com> Change-Id: Icd6b09cdf57b40be6c7ebd11c527036240f248eb
-rw-r--r--recipes-demo/html5-launcher/html5-launcher_git.bb7
1 files changed, 4 insertions, 3 deletions
diff --git a/recipes-demo/html5-launcher/html5-launcher_git.bb b/recipes-demo/html5-launcher/html5-launcher_git.bb
index 61899e4c..5c70fd77 100644
--- a/recipes-demo/html5-launcher/html5-launcher_git.bb
+++ b/recipes-demo/html5-launcher/html5-launcher_git.bb
@@ -17,9 +17,10 @@ SRCREV = "${AGL_APP_REVISION}"
DEPENDS = "nodejs-native"
do_compile() {
- bldcmd=${S}/autobuild/agl/autobuild
cd ${S}
- $bldcmd build
+ rm -rf package node_modules package-lock.json
+ npm install
+ npm run build
}
WAM_APPLICATIONS_DIR="${libdir}/wam_apps"
@@ -38,4 +39,4 @@ FILES_${PN} = " \
"
RCONFLICTS_${PN} = "launcher"
-RDEPENDS_${PN} = "applaunchd" \ No newline at end of file
+RDEPENDS_${PN} = "applaunchd"