summaryrefslogtreecommitdiffstats
path: root/recipes-config/cluster-demo-network-config/cluster-demo-network-config_1.0.bb
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2021-11-03 15:18:49 +0100
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>2021-11-03 22:43:56 +0100
commit1b72a0f90fa7d1b45eb1017629cc83dcd8971c48 (patch)
treedecc406f376b968d90fade3c321777e068a8c00e /recipes-config/cluster-demo-network-config/cluster-demo-network-config_1.0.bb
parent94a051785cdb588bc3a475a5490f1f286176d646 (diff)
Prepare master for new framework integration
During the last workshop the transition to the new framework was presented. This change essentially deprecates the SMACK-based application framework. To prepare the integration of it, we remove the deprecated components: - recipes-apis : all agl-service-* - recipes-demos: all demo apps but homescreen - non-essential configurations Todo: We need to bring-back the html5 image in a follow-up w/o ties into the old framework. v2: kept WAM + Chromium recipes for reference v3: rebased Bug-AGL: SPEC-4121 Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Change-Id: I58075f5f1e477106a1aad3d2171a0904bf0cb16e
Diffstat (limited to 'recipes-config/cluster-demo-network-config/cluster-demo-network-config_1.0.bb')
-rw-r--r--recipes-config/cluster-demo-network-config/cluster-demo-network-config_1.0.bb33
1 files changed, 0 insertions, 33 deletions
diff --git a/recipes-config/cluster-demo-network-config/cluster-demo-network-config_1.0.bb b/recipes-config/cluster-demo-network-config/cluster-demo-network-config_1.0.bb
deleted file mode 100644
index 8d737282..00000000
--- a/recipes-config/cluster-demo-network-config/cluster-demo-network-config_1.0.bb
+++ /dev/null
@@ -1,33 +0,0 @@
-SUMMARY = "Setting files for cluster network for the AGL Demonstrator"
-DESCRIPTION = "Setting files for cluster network for the AGL Demonstrator"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
-
-inherit systemd allarch
-
-SRC_URI = "file://cluster-demo-network-conf@.service \
- file://cluster-demo-network-conf.sh \
-"
-
-# Network device for dedicated connection to cluster
-AGL_CLUSTER_NET_DEVICE ?= "eth1"
-
-do_configure[noexec] = "1"
-do_compile[noexec] = "1"
-
-do_install() {
- # Install helper script
- install -d ${D}${sbindir}
- install -m 0755 ${WORKDIR}/cluster-demo-network-conf.sh ${D}${sbindir}/
-
- # Install service unit
- install -d ${D}${systemd_system_unitdir}
- install -m 0644 ${WORKDIR}/cluster-demo-network-conf@.service ${D}${systemd_system_unitdir}/
-
- # Add symlink to network.target.wants
- install -d ${D}${sysconfdir}/systemd/system/network.target.wants
- ln -s ${systemd_system_unitdir}/cluster-demo-network-conf@.service \
- ${D}${sysconfdir}/systemd/system/network.target.wants/cluster-demo-network-conf@${AGL_CLUSTER_NET_DEVICE}.service
-}
-
-FILES:${PN} += "${systemd_system_unitdir}"