summaryrefslogtreecommitdiffstats
path: root/recipes-config
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2019-12-29 18:30:47 -0500
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2019-12-30 14:56:48 +0000
commit0c284fb6273dc039c1573e2f6681e9c56708d0f1 (patch)
treebddb185b36154297bbff241274877461351993fc /recipes-config
parent53c91e75b2ddc60c4c888a7a82bb343bbe3cdcaf (diff)
Add demo low-can device mapping
Rework the agl-demo-preload feature to specify a new demo-specific PREFERRED_RPROVIDER for the new virtual/low-can-dev-mapping virtual package. This enables using the sllin0 interface on the CES demo setup as the low-speed interface. Bug-AGL: SPEC-3076 Change-Id: I872137d8acb1f5ec5df9eac92f25953b28128b36 Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Diffstat (limited to 'recipes-config')
-rw-r--r--recipes-config/dev-mapping-demo/dev-mapping-demo/dev-mapping.conf.demo6
-rw-r--r--recipes-config/dev-mapping-demo/dev-mapping-demo_1.0.bb18
2 files changed, 24 insertions, 0 deletions
diff --git a/recipes-config/dev-mapping-demo/dev-mapping-demo/dev-mapping.conf.demo b/recipes-config/dev-mapping-demo/dev-mapping-demo/dev-mapping.conf.demo
new file mode 100644
index 00000000..93b0a020
--- /dev/null
+++ b/recipes-config/dev-mapping-demo/dev-mapping-demo/dev-mapping.conf.demo
@@ -0,0 +1,6 @@
+; Default CAN device mapping
+; Format has to follow ini rules key="value", notice " around value.
+
+[CANbus-mapping]
+hs="can0"
+ls="sllin0"
diff --git a/recipes-config/dev-mapping-demo/dev-mapping-demo_1.0.bb b/recipes-config/dev-mapping-demo/dev-mapping-demo_1.0.bb
new file mode 100644
index 00000000..4a04ce13
--- /dev/null
+++ b/recipes-config/dev-mapping-demo/dev-mapping-demo_1.0.bb
@@ -0,0 +1,18 @@
+SUMMARY = "AGL demo device mapping configuration file"
+DESCRIPTION = "This provide default dev-mapping.conf file \
+ that defines mapping between kernel device and logical name \
+ used in low-can binding for the AGL demo setup."
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+
+SRC_URI += "file://dev-mapping.conf.demo"
+
+inherit allarch
+
+do_install() {
+ install -d ${D}${sysconfdir}
+ install -m 0644 ${WORKDIR}/dev-mapping.conf.demo ${D}${sysconfdir}/dev-mapping.conf
+}
+
+RPROVIDES_${PN} = "virtual/low-can-dev-mapping"