summaryrefslogtreecommitdiffstats
path: root/recipes-core/base-files-guest
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2024-05-23 10:21:50 -0400
committerScott Murray <scott.murray@konsulko.com>2024-12-19 22:41:31 -0500
commitb8f5c41d1d447795ffa72e3ceeeaf12f6f0e1605 (patch)
tree7db11a20de9ca399678bbd8c12b70cdf394b85e4 /recipes-core/base-files-guest
parentd100e89de22d6a950b3caab4d060b7e8dc3f4e15 (diff)
Update recipes for transition to UNPACKDIRnext
Update recipes to handle the transition to using UNPACKDIR as the destination for unpacked files. For recipes that had been using S = WORKDIR, the approach used in meta-openembedded has been followed, i.e. using UNPACKDIR in tasks for consistency. Bug-AGL: SPEC-5147 Change-Id: I42b2b474be163c66e11a449de6eec7d748e00fbb Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Diffstat (limited to 'recipes-core/base-files-guest')
-rw-r--r--recipes-core/base-files-guest/base-files-guest-fstab_1.0.0.bb11
1 files changed, 4 insertions, 7 deletions
diff --git a/recipes-core/base-files-guest/base-files-guest-fstab_1.0.0.bb b/recipes-core/base-files-guest/base-files-guest-fstab_1.0.0.bb
index ad3e6e940..ccc907a79 100644
--- a/recipes-core/base-files-guest/base-files-guest-fstab_1.0.0.bb
+++ b/recipes-core/base-files-guest/base-files-guest-fstab_1.0.0.bb
@@ -4,17 +4,14 @@ SECTION = "base"
LICENSE = "GPL-2.0-only"
LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0-only;md5=801f80980d171dd6425610833a22dbe6"
-SRC_URI = " \
- file://fstab \
-"
-S = "${WORKDIR}"
+SRC_URI = "file://fstab"
-#INHIBIT_DEFAULT_DEPS = "1"
+S = "${WORKDIR}/sources"
+UNPACKDIR = "${S}"
do_install () {
install -m 0755 -d ${D}${sysconfdir}
-
- install -m 0644 ${WORKDIR}/fstab ${D}${sysconfdir}/fstab-guest
+ install -m 0644 ${UNPACKDIR}/fstab ${D}${sysconfdir}/fstab-guest
}
PACKAGES = "${PN}"