summaryrefslogtreecommitdiffstats
path: root/recipes-core
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2024-05-23 10:21:50 -0400
committerjenkins-dontreply@build.automotivelinux.org <collab-it+agl-jobbuilder@linuxfoundation.org>2024-08-17 12:37:34 +0000
commit62c27830707e134dfe18662fb304c5905ead49af (patch)
tree776975c7a0eaf09b5ccdc4a0c8d8879d2dbd1a21 /recipes-core
parentda95381c1a7f3ad1455cd0da8da48d34b187186b (diff)
Update recipes for transition to UNPACKDIRnext
Update recipes to handle the transition to using UNPACKDIR as the destination for unpacked files. For recipes that had been using S = WORKDIR, the approach used in meta-openembedded has been followed, i.e. using UNPACKDIR in tasks for consistency. Bug-AGL: SPEC-5147 Change-Id: I42b2b474be163c66e11a449de6eec7d748e00fbb Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Diffstat (limited to 'recipes-core')
-rw-r--r--recipes-core/base-files-guest/base-files-guest-fstab_1.0.0.bb11
-rw-r--r--recipes-core/dbus/dbus_agldemo.inc6
-rw-r--r--recipes-core/psplash/psplash-inverted-config.bb5
-rw-r--r--recipes-core/psplash/psplash-portrait-config.bb5
-rw-r--r--recipes-core/psplash/psplash_agldemo.inc4
-rw-r--r--recipes-core/udev/demo-i2c-udev-conf_1.0.bb15
-rw-r--r--recipes-core/udev/output-udev-conf_1.0.bb5
-rw-r--r--recipes-core/udev/sw-gpsd-udev-conf_1.0.bb5
-rw-r--r--recipes-core/udev/usb-can-udev-conf_1.0.bb9
9 files changed, 40 insertions, 25 deletions
diff --git a/recipes-core/base-files-guest/base-files-guest-fstab_1.0.0.bb b/recipes-core/base-files-guest/base-files-guest-fstab_1.0.0.bb
index ad3e6e940..ccc907a79 100644
--- a/recipes-core/base-files-guest/base-files-guest-fstab_1.0.0.bb
+++ b/recipes-core/base-files-guest/base-files-guest-fstab_1.0.0.bb
@@ -4,17 +4,14 @@ SECTION = "base"
LICENSE = "GPL-2.0-only"
LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0-only;md5=801f80980d171dd6425610833a22dbe6"
-SRC_URI = " \
- file://fstab \
-"
-S = "${WORKDIR}"
+SRC_URI = "file://fstab"
-#INHIBIT_DEFAULT_DEPS = "1"
+S = "${WORKDIR}/sources"
+UNPACKDIR = "${S}"
do_install () {
install -m 0755 -d ${D}${sysconfdir}
-
- install -m 0644 ${WORKDIR}/fstab ${D}${sysconfdir}/fstab-guest
+ install -m 0644 ${UNPACKDIR}/fstab ${D}${sysconfdir}/fstab-guest
}
PACKAGES = "${PN}"
diff --git a/recipes-core/dbus/dbus_agldemo.inc b/recipes-core/dbus/dbus_agldemo.inc
index 826584c05..8f5a2955f 100644
--- a/recipes-core/dbus/dbus_agldemo.inc
+++ b/recipes-core/dbus/dbus_agldemo.inc
@@ -10,9 +10,9 @@ inherit systemd
do_install:append() {
if [ "${PN}" != "nativesdk-dbus" ]; then
if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
- install -m 644 -p -D ${WORKDIR}/dbus.service ${D}${systemd_user_unitdir}/dbus.service
- install -m 644 -p -D ${WORKDIR}/dbus.socket ${D}${systemd_user_unitdir}/dbus.socket
- install -m 644 -p -D ${WORKDIR}/dbus_env.conf ${D}${systemd_system_unitdir}/user@.service.d/dbus_env.conf
+ install -m 644 -p -D ${UNPACKDIR}/dbus.service ${D}${systemd_user_unitdir}/dbus.service
+ install -m 644 -p -D ${UNPACKDIR}/dbus.socket ${D}${systemd_user_unitdir}/dbus.socket
+ install -m 644 -p -D ${UNPACKDIR}/dbus_env.conf ${D}${systemd_system_unitdir}/user@.service.d/dbus_env.conf
# Execute these manually on behalf of systemctl script (from systemd-systemctl-native.bb)
# because it does not support systemd's user mode.
diff --git a/recipes-core/psplash/psplash-inverted-config.bb b/recipes-core/psplash/psplash-inverted-config.bb
index f11b255da..0bc067cf0 100644
--- a/recipes-core/psplash/psplash-inverted-config.bb
+++ b/recipes-core/psplash/psplash-inverted-config.bb
@@ -6,13 +6,16 @@ inherit systemd allarch
SRC_URI = "file://psplash-inverted.conf"
+S = "${WORKDIR}/sources"
+UNPACKDIR = "${S}"
+
do_configure[noexec] = "1"
do_compile[noexec] = "1"
do_install() {
# Install override
install -d ${D}${systemd_system_unitdir}/psplash-start.service.d
- install -m 0644 ${WORKDIR}/psplash-inverted.conf ${D}${systemd_system_unitdir}/psplash-start.service.d/
+ install -m 0644 ${UNPACKDIR}/psplash-inverted.conf ${D}${systemd_system_unitdir}/psplash-start.service.d/
}
FILES:${PN} += "${systemd_system_unitdir}"
diff --git a/recipes-core/psplash/psplash-portrait-config.bb b/recipes-core/psplash/psplash-portrait-config.bb
index 7afee442c..8b32dc2dd 100644
--- a/recipes-core/psplash/psplash-portrait-config.bb
+++ b/recipes-core/psplash/psplash-portrait-config.bb
@@ -6,13 +6,16 @@ inherit systemd allarch
SRC_URI = "file://psplash-portrait.conf"
+S = "${WORKDIR}/sources"
+UNPACKDIR = "${S}"
+
do_configure[noexec] = "1"
do_compile[noexec] = "1"
do_install() {
# Install override
install -d ${D}${systemd_system_unitdir}/psplash-start.service.d
- install -m 0644 ${WORKDIR}/psplash-portrait.conf ${D}${systemd_system_unitdir}/psplash-start.service.d/
+ install -m 0644 ${UNPACKDIR}/psplash-portrait.conf ${D}${systemd_system_unitdir}/psplash-start.service.d/
}
FILES:${PN} += "${systemd_system_unitdir}"
diff --git a/recipes-core/psplash/psplash_agldemo.inc b/recipes-core/psplash/psplash_agldemo.inc
index cc5b5b7b6..93d4b0583 100644
--- a/recipes-core/psplash/psplash_agldemo.inc
+++ b/recipes-core/psplash/psplash_agldemo.inc
@@ -8,13 +8,13 @@ SRC_URI:append = " \
SPLASH_IMAGES = "file://psplash-poky-img.h;outsuffix=default"
do_configure:append () {
- cp -f ${WORKDIR}/psplash-colors.h ${S}
+ cp -f ${UNPACKDIR}/psplash-colors.h ${S}
}
do_install:append () {
# Install override
install -d ${D}${systemd_system_unitdir}/psplash-start.service.d
- install -m 0644 ${WORKDIR}/psplash-args.conf ${D}${systemd_system_unitdir}/psplash-start.service.d/
+ install -m 0644 ${UNPACKDIR}/psplash-args.conf ${D}${systemd_system_unitdir}/psplash-start.service.d/
}
FILES:${PN} += "${systemd_system_unitdir}"
diff --git a/recipes-core/udev/demo-i2c-udev-conf_1.0.bb b/recipes-core/udev/demo-i2c-udev-conf_1.0.bb
index 7707df60a..11f95469f 100644
--- a/recipes-core/udev/demo-i2c-udev-conf_1.0.bb
+++ b/recipes-core/udev/demo-i2c-udev-conf_1.0.bb
@@ -10,23 +10,26 @@ SRC_URI = "file://hvac-conf-in-rewrite.sh \
file://agl-service-hvac-leds.conf.in \
"
+S = "${WORKDIR}/sources"
+UNPACKDIR = "${S}"
+
do_compile[noexec] = "1"
do_install() {
install -d ${D}${sysconfdir}/xdg/AGL
- install -m 0644 ${WORKDIR}/agl-service-hvac-leds.conf.in ${D}${sysconfdir}/xdg/AGL
+ install -m 0644 ${UNPACKDIR}/agl-service-hvac-leds.conf.in ${D}${sysconfdir}/xdg/AGL
install -d ${D}${sbindir}
- install -m 0755 ${WORKDIR}/hvac-conf-in-rewrite.sh ${D}${sbindir}
- install -m 0755 ${WORKDIR}/rtc-i2c-attach.sh ${D}${sbindir}
+ install -m 0755 ${UNPACKDIR}/hvac-conf-in-rewrite.sh ${D}${sbindir}
+ install -m 0755 ${UNPACKDIR}/rtc-i2c-attach.sh ${D}${sbindir}
if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
install -d ${D}${systemd_system_unitdir}
- install -m 0644 ${WORKDIR}/hvac-conf-in-rewrite@.service ${D}${systemd_system_unitdir}
- install -m 0644 ${WORKDIR}/rtc-i2c-attach@.service ${D}${systemd_system_unitdir}
+ install -m 0644 ${UNPACKDIR}/hvac-conf-in-rewrite@.service ${D}${systemd_system_unitdir}
+ install -m 0644 ${UNPACKDIR}/rtc-i2c-attach@.service ${D}${systemd_system_unitdir}
install -d ${D}${sysconfdir}/udev/rules.d
- install -m 0644 ${WORKDIR}/99-agl-led-rtc.rules ${D}${sysconfdir}/udev/rules.d/
+ install -m 0644 ${UNPACKDIR}/99-agl-led-rtc.rules ${D}${sysconfdir}/udev/rules.d/
fi
}
diff --git a/recipes-core/udev/output-udev-conf_1.0.bb b/recipes-core/udev/output-udev-conf_1.0.bb
index c4e05ad02..73273feff 100644
--- a/recipes-core/udev/output-udev-conf_1.0.bb
+++ b/recipes-core/udev/output-udev-conf_1.0.bb
@@ -4,12 +4,15 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384
SRC_URI = "file://91-output.rules"
+S = "${WORKDIR}/sources"
+UNPACKDIR = "${S}"
+
do_compile[noexec] = "1"
do_install() {
if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
install -d ${D}${sysconfdir}/udev/rules.d
- install -m 0644 ${WORKDIR}/91-output.rules ${D}${sysconfdir}/udev/rules.d/
+ install -m 0644 ${UNPACKDIR}/91-output.rules ${D}${sysconfdir}/udev/rules.d/
fi
}
diff --git a/recipes-core/udev/sw-gpsd-udev-conf_1.0.bb b/recipes-core/udev/sw-gpsd-udev-conf_1.0.bb
index bcad0f41b..d6572b7c8 100644
--- a/recipes-core/udev/sw-gpsd-udev-conf_1.0.bb
+++ b/recipes-core/udev/sw-gpsd-udev-conf_1.0.bb
@@ -4,12 +4,15 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384
SRC_URI = "file://60-sw-gpsd.rules"
+S = "${WORKDIR}/sources"
+UNPACKDIR = "${S}"
+
do_compile[noexec] = "1"
do_install() {
if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
install -d ${D}${sysconfdir}/udev/rules.d
- install -m 0644 ${WORKDIR}/60-sw-gpsd.rules ${D}${sysconfdir}/udev/rules.d/
+ install -m 0644 ${UNPACKDIR}/60-sw-gpsd.rules ${D}${sysconfdir}/udev/rules.d/
fi
}
diff --git a/recipes-core/udev/usb-can-udev-conf_1.0.bb b/recipes-core/udev/usb-can-udev-conf_1.0.bb
index 1b76550da..6b92d5823 100644
--- a/recipes-core/udev/usb-can-udev-conf_1.0.bb
+++ b/recipes-core/udev/usb-can-udev-conf_1.0.bb
@@ -7,16 +7,19 @@ SRC_URI = "file://60-usb-can.rules \
file://slcand-default \
"
+S = "${WORKDIR}/sources"
+UNPACKDIR = "${S}"
+
do_compile[noexec] = "1"
do_install() {
if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
install -d ${D}${sysconfdir}/udev/rules.d
- install -m 0644 ${WORKDIR}/60-usb-can.rules ${D}${sysconfdir}/udev/rules.d/
+ install -m 0644 ${UNPACKDIR}/60-usb-can.rules ${D}${sysconfdir}/udev/rules.d/
install -d ${D}${systemd_system_unitdir}
- install -m 0644 ${WORKDIR}/slcand@.service ${D}${systemd_system_unitdir}/
+ install -m 0644 ${UNPACKDIR}/slcand@.service ${D}${systemd_system_unitdir}/
install -d ${D}${sysconfdir}/default
- install -m 0644 ${WORKDIR}/slcand-default ${D}${sysconfdir}/default/slcand
+ install -m 0644 ${UNPACKDIR}/slcand-default ${D}${sysconfdir}/default/slcand
fi
}