summaryrefslogtreecommitdiffstats
path: root/recipes-core
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core')
-rw-r--r--recipes-core/base-files-guest/base-files-guest-fstab_1.0.0.bb11
-rw-r--r--recipes-core/dbus/dbus_agldemo.inc6
-rw-r--r--recipes-core/nss/nss-agl-driver-db_git.bb7
-rw-r--r--recipes-core/psplash/psplash-inverted-config.bb5
-rw-r--r--recipes-core/psplash/psplash-portrait-config.bb5
-rw-r--r--recipes-core/psplash/psplash_agldemo.inc4
-rw-r--r--recipes-core/udev/demo-i2c-udev-conf_1.0.bb15
-rw-r--r--recipes-core/udev/output-udev-conf_1.0.bb5
-rw-r--r--recipes-core/udev/sw-gpsd-udev-conf_1.0.bb5
-rw-r--r--recipes-core/udev/usb-can-udev-conf_1.0.bb9
10 files changed, 45 insertions, 27 deletions
diff --git a/recipes-core/base-files-guest/base-files-guest-fstab_1.0.0.bb b/recipes-core/base-files-guest/base-files-guest-fstab_1.0.0.bb
index ad3e6e94..ccc907a7 100644
--- a/recipes-core/base-files-guest/base-files-guest-fstab_1.0.0.bb
+++ b/recipes-core/base-files-guest/base-files-guest-fstab_1.0.0.bb
@@ -4,17 +4,14 @@ SECTION = "base"
LICENSE = "GPL-2.0-only"
LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0-only;md5=801f80980d171dd6425610833a22dbe6"
-SRC_URI = " \
- file://fstab \
-"
-S = "${WORKDIR}"
+SRC_URI = "file://fstab"
-#INHIBIT_DEFAULT_DEPS = "1"
+S = "${WORKDIR}/sources"
+UNPACKDIR = "${S}"
do_install () {
install -m 0755 -d ${D}${sysconfdir}
-
- install -m 0644 ${WORKDIR}/fstab ${D}${sysconfdir}/fstab-guest
+ install -m 0644 ${UNPACKDIR}/fstab ${D}${sysconfdir}/fstab-guest
}
PACKAGES = "${PN}"
diff --git a/recipes-core/dbus/dbus_agldemo.inc b/recipes-core/dbus/dbus_agldemo.inc
index 826584c0..8f5a2955 100644
--- a/recipes-core/dbus/dbus_agldemo.inc
+++ b/recipes-core/dbus/dbus_agldemo.inc
@@ -10,9 +10,9 @@ inherit systemd
do_install:append() {
if [ "${PN}" != "nativesdk-dbus" ]; then
if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
- install -m 644 -p -D ${WORKDIR}/dbus.service ${D}${systemd_user_unitdir}/dbus.service
- install -m 644 -p -D ${WORKDIR}/dbus.socket ${D}${systemd_user_unitdir}/dbus.socket
- install -m 644 -p -D ${WORKDIR}/dbus_env.conf ${D}${systemd_system_unitdir}/user@.service.d/dbus_env.conf
+ install -m 644 -p -D ${UNPACKDIR}/dbus.service ${D}${systemd_user_unitdir}/dbus.service
+ install -m 644 -p -D ${UNPACKDIR}/dbus.socket ${D}${systemd_user_unitdir}/dbus.socket
+ install -m 644 -p -D ${UNPACKDIR}/dbus_env.conf ${D}${systemd_system_unitdir}/user@.service.d/dbus_env.conf
# Execute these manually on behalf of systemctl script (from systemd-systemctl-native.bb)
# because it does not support systemd's user mode.
diff --git a/recipes-core/nss/nss-agl-driver-db_git.bb b/recipes-core/nss/nss-agl-driver-db_git.bb
index b2fb4034..84cb34ed 100644
--- a/recipes-core/nss/nss-agl-driver-db_git.bb
+++ b/recipes-core/nss/nss-agl-driver-db_git.bb
@@ -11,6 +11,9 @@ SRC_URI = "file://${BPN}.service \
file://${BPN}.sh \
"
+S = "${WORKDIR}/sources"
+UNPACKDIR = "${S}"
+
inherit systemd
SYSTEMD_SERVICE:${PN} = "${BPN}.service"
@@ -22,8 +25,8 @@ do_install() {
if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
install -d ${D}${systemd_system_unitdir}
install -d ${D}${sbindir}
- install -m 0644 ${WORKDIR}/${BPN}.service ${D}${systemd_system_unitdir}
- install -m 0755 ${WORKDIR}/${BPN}.sh ${D}${sbindir}
+ install -m 0644 ${UNPACKDIR}/${BPN}.service ${D}${systemd_system_unitdir}
+ install -m 0755 ${UNPACKDIR}/${BPN}.sh ${D}${sbindir}
fi
}
diff --git a/recipes-core/psplash/psplash-inverted-config.bb b/recipes-core/psplash/psplash-inverted-config.bb
index f11b255d..0bc067cf 100644
--- a/recipes-core/psplash/psplash-inverted-config.bb
+++ b/recipes-core/psplash/psplash-inverted-config.bb
@@ -6,13 +6,16 @@ inherit systemd allarch
SRC_URI = "file://psplash-inverted.conf"
+S = "${WORKDIR}/sources"
+UNPACKDIR = "${S}"
+
do_configure[noexec] = "1"
do_compile[noexec] = "1"
do_install() {
# Install override
install -d ${D}${systemd_system_unitdir}/psplash-start.service.d
- install -m 0644 ${WORKDIR}/psplash-inverted.conf ${D}${systemd_system_unitdir}/psplash-start.service.d/
+ install -m 0644 ${UNPACKDIR}/psplash-inverted.conf ${D}${systemd_system_unitdir}/psplash-start.service.d/
}
FILES:${PN} += "${systemd_system_unitdir}"
diff --git a/recipes-core/psplash/psplash-portrait-config.bb b/recipes-core/psplash/psplash-portrait-config.bb
index 7afee442..8b32dc2d 100644
--- a/recipes-core/psplash/psplash-portrait-config.bb
+++ b/recipes-core/psplash/psplash-portrait-config.bb
@@ -6,13 +6,16 @@ inherit systemd allarch
SRC_URI = "file://psplash-portrait.conf"
+S = "${WORKDIR}/sources"
+UNPACKDIR = "${S}"
+
do_configure[noexec] = "1"
do_compile[noexec] = "1"
do_install() {
# Install override
install -d ${D}${systemd_system_unitdir}/psplash-start.service.d
- install -m 0644 ${WORKDIR}/psplash-portrait.conf ${D}${systemd_system_unitdir}/psplash-start.service.d/
+ install -m 0644 ${UNPACKDIR}/psplash-portrait.conf ${D}${systemd_system_unitdir}/psplash-start.service.d/
}
FILES:${PN} += "${systemd_system_unitdir}"
diff --git a/recipes-core/psplash/psplash_agldemo.inc b/recipes-core/psplash/psplash_agldemo.inc
index cc5b5b7b..93d4b058 100644
--- a/recipes-core/psplash/psplash_agldemo.inc
+++ b/recipes-core/psplash/psplash_agldemo.inc
@@ -8,13 +8,13 @@ SRC_URI:append = " \
SPLASH_IMAGES = "file://psplash-poky-img.h;outsuffix=default"
do_configure:append () {
- cp -f ${WORKDIR}/psplash-colors.h ${S}
+ cp -f ${UNPACKDIR}/psplash-colors.h ${S}
}
do_install:append () {
# Install override
install -d ${D}${systemd_system_unitdir}/psplash-start.service.d
- install -m 0644 ${WORKDIR}/psplash-args.conf ${D}${systemd_system_unitdir}/psplash-start.service.d/
+ install -m 0644 ${UNPACKDIR}/psplash-args.conf ${D}${systemd_system_unitdir}/psplash-start.service.d/
}
FILES:${PN} += "${systemd_system_unitdir}"
diff --git a/recipes-core/udev/demo-i2c-udev-conf_1.0.bb b/recipes-core/udev/demo-i2c-udev-conf_1.0.bb
index 7707df60..11f95469 100644
--- a/recipes-core/udev/demo-i2c-udev-conf_1.0.bb
+++ b/recipes-core/udev/demo-i2c-udev-conf_1.0.bb
@@ -10,23 +10,26 @@ SRC_URI = "file://hvac-conf-in-rewrite.sh \
file://agl-service-hvac-leds.conf.in \
"
+S = "${WORKDIR}/sources"
+UNPACKDIR = "${S}"
+
do_compile[noexec] = "1"
do_install() {
install -d ${D}${sysconfdir}/xdg/AGL
- install -m 0644 ${WORKDIR}/agl-service-hvac-leds.conf.in ${D}${sysconfdir}/xdg/AGL
+ install -m 0644 ${UNPACKDIR}/agl-service-hvac-leds.conf.in ${D}${sysconfdir}/xdg/AGL
install -d ${D}${sbindir}
- install -m 0755 ${WORKDIR}/hvac-conf-in-rewrite.sh ${D}${sbindir}
- install -m 0755 ${WORKDIR}/rtc-i2c-attach.sh ${D}${sbindir}
+ install -m 0755 ${UNPACKDIR}/hvac-conf-in-rewrite.sh ${D}${sbindir}
+ install -m 0755 ${UNPACKDIR}/rtc-i2c-attach.sh ${D}${sbindir}
if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
install -d ${D}${systemd_system_unitdir}
- install -m 0644 ${WORKDIR}/hvac-conf-in-rewrite@.service ${D}${systemd_system_unitdir}
- install -m 0644 ${WORKDIR}/rtc-i2c-attach@.service ${D}${systemd_system_unitdir}
+ install -m 0644 ${UNPACKDIR}/hvac-conf-in-rewrite@.service ${D}${systemd_system_unitdir}
+ install -m 0644 ${UNPACKDIR}/rtc-i2c-attach@.service ${D}${systemd_system_unitdir}
install -d ${D}${sysconfdir}/udev/rules.d
- install -m 0644 ${WORKDIR}/99-agl-led-rtc.rules ${D}${sysconfdir}/udev/rules.d/
+ install -m 0644 ${UNPACKDIR}/99-agl-led-rtc.rules ${D}${sysconfdir}/udev/rules.d/
fi
}
diff --git a/recipes-core/udev/output-udev-conf_1.0.bb b/recipes-core/udev/output-udev-conf_1.0.bb
index c4e05ad0..73273fef 100644
--- a/recipes-core/udev/output-udev-conf_1.0.bb
+++ b/recipes-core/udev/output-udev-conf_1.0.bb
@@ -4,12 +4,15 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384
SRC_URI = "file://91-output.rules"
+S = "${WORKDIR}/sources"
+UNPACKDIR = "${S}"
+
do_compile[noexec] = "1"
do_install() {
if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
install -d ${D}${sysconfdir}/udev/rules.d
- install -m 0644 ${WORKDIR}/91-output.rules ${D}${sysconfdir}/udev/rules.d/
+ install -m 0644 ${UNPACKDIR}/91-output.rules ${D}${sysconfdir}/udev/rules.d/
fi
}
diff --git a/recipes-core/udev/sw-gpsd-udev-conf_1.0.bb b/recipes-core/udev/sw-gpsd-udev-conf_1.0.bb
index bcad0f41..d6572b7c 100644
--- a/recipes-core/udev/sw-gpsd-udev-conf_1.0.bb
+++ b/recipes-core/udev/sw-gpsd-udev-conf_1.0.bb
@@ -4,12 +4,15 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384
SRC_URI = "file://60-sw-gpsd.rules"
+S = "${WORKDIR}/sources"
+UNPACKDIR = "${S}"
+
do_compile[noexec] = "1"
do_install() {
if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
install -d ${D}${sysconfdir}/udev/rules.d
- install -m 0644 ${WORKDIR}/60-sw-gpsd.rules ${D}${sysconfdir}/udev/rules.d/
+ install -m 0644 ${UNPACKDIR}/60-sw-gpsd.rules ${D}${sysconfdir}/udev/rules.d/
fi
}
diff --git a/recipes-core/udev/usb-can-udev-conf_1.0.bb b/recipes-core/udev/usb-can-udev-conf_1.0.bb
index 1b76550d..6b92d582 100644
--- a/recipes-core/udev/usb-can-udev-conf_1.0.bb
+++ b/recipes-core/udev/usb-can-udev-conf_1.0.bb
@@ -7,16 +7,19 @@ SRC_URI = "file://60-usb-can.rules \
file://slcand-default \
"
+S = "${WORKDIR}/sources"
+UNPACKDIR = "${S}"
+
do_compile[noexec] = "1"
do_install() {
if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
install -d ${D}${sysconfdir}/udev/rules.d
- install -m 0644 ${WORKDIR}/60-usb-can.rules ${D}${sysconfdir}/udev/rules.d/
+ install -m 0644 ${UNPACKDIR}/60-usb-can.rules ${D}${sysconfdir}/udev/rules.d/
install -d ${D}${systemd_system_unitdir}
- install -m 0644 ${WORKDIR}/slcand@.service ${D}${systemd_system_unitdir}/
+ install -m 0644 ${UNPACKDIR}/slcand@.service ${D}${systemd_system_unitdir}/
install -d ${D}${sysconfdir}/default
- install -m 0644 ${WORKDIR}/slcand-default ${D}${sysconfdir}/default/slcand
+ install -m 0644 ${UNPACKDIR}/slcand-default ${D}${sysconfdir}/default/slcand
fi
}