summaryrefslogtreecommitdiffstats
path: root/recipes-core/psplash
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2024-05-23 10:21:50 -0400
committerjenkins-dontreply@build.automotivelinux.org <collab-it+agl-jobbuilder@linuxfoundation.org>2024-08-17 12:37:34 +0000
commit62c27830707e134dfe18662fb304c5905ead49af (patch)
tree776975c7a0eaf09b5ccdc4a0c8d8879d2dbd1a21 /recipes-core/psplash
parentda95381c1a7f3ad1455cd0da8da48d34b187186b (diff)
Update recipes for transition to UNPACKDIRnext
Update recipes to handle the transition to using UNPACKDIR as the destination for unpacked files. For recipes that had been using S = WORKDIR, the approach used in meta-openembedded has been followed, i.e. using UNPACKDIR in tasks for consistency. Bug-AGL: SPEC-5147 Change-Id: I42b2b474be163c66e11a449de6eec7d748e00fbb Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Diffstat (limited to 'recipes-core/psplash')
-rw-r--r--recipes-core/psplash/psplash-inverted-config.bb5
-rw-r--r--recipes-core/psplash/psplash-portrait-config.bb5
-rw-r--r--recipes-core/psplash/psplash_agldemo.inc4
3 files changed, 10 insertions, 4 deletions
diff --git a/recipes-core/psplash/psplash-inverted-config.bb b/recipes-core/psplash/psplash-inverted-config.bb
index f11b255da..0bc067cf0 100644
--- a/recipes-core/psplash/psplash-inverted-config.bb
+++ b/recipes-core/psplash/psplash-inverted-config.bb
@@ -6,13 +6,16 @@ inherit systemd allarch
SRC_URI = "file://psplash-inverted.conf"
+S = "${WORKDIR}/sources"
+UNPACKDIR = "${S}"
+
do_configure[noexec] = "1"
do_compile[noexec] = "1"
do_install() {
# Install override
install -d ${D}${systemd_system_unitdir}/psplash-start.service.d
- install -m 0644 ${WORKDIR}/psplash-inverted.conf ${D}${systemd_system_unitdir}/psplash-start.service.d/
+ install -m 0644 ${UNPACKDIR}/psplash-inverted.conf ${D}${systemd_system_unitdir}/psplash-start.service.d/
}
FILES:${PN} += "${systemd_system_unitdir}"
diff --git a/recipes-core/psplash/psplash-portrait-config.bb b/recipes-core/psplash/psplash-portrait-config.bb
index 7afee442c..8b32dc2dd 100644
--- a/recipes-core/psplash/psplash-portrait-config.bb
+++ b/recipes-core/psplash/psplash-portrait-config.bb
@@ -6,13 +6,16 @@ inherit systemd allarch
SRC_URI = "file://psplash-portrait.conf"
+S = "${WORKDIR}/sources"
+UNPACKDIR = "${S}"
+
do_configure[noexec] = "1"
do_compile[noexec] = "1"
do_install() {
# Install override
install -d ${D}${systemd_system_unitdir}/psplash-start.service.d
- install -m 0644 ${WORKDIR}/psplash-portrait.conf ${D}${systemd_system_unitdir}/psplash-start.service.d/
+ install -m 0644 ${UNPACKDIR}/psplash-portrait.conf ${D}${systemd_system_unitdir}/psplash-start.service.d/
}
FILES:${PN} += "${systemd_system_unitdir}"
diff --git a/recipes-core/psplash/psplash_agldemo.inc b/recipes-core/psplash/psplash_agldemo.inc
index cc5b5b7b6..93d4b0583 100644
--- a/recipes-core/psplash/psplash_agldemo.inc
+++ b/recipes-core/psplash/psplash_agldemo.inc
@@ -8,13 +8,13 @@ SRC_URI:append = " \
SPLASH_IMAGES = "file://psplash-poky-img.h;outsuffix=default"
do_configure:append () {
- cp -f ${WORKDIR}/psplash-colors.h ${S}
+ cp -f ${UNPACKDIR}/psplash-colors.h ${S}
}
do_install:append () {
# Install override
install -d ${D}${systemd_system_unitdir}/psplash-start.service.d
- install -m 0644 ${WORKDIR}/psplash-args.conf ${D}${systemd_system_unitdir}/psplash-start.service.d/
+ install -m 0644 ${UNPACKDIR}/psplash-args.conf ${D}${systemd_system_unitdir}/psplash-start.service.d/
}
FILES:${PN} += "${systemd_system_unitdir}"