summaryrefslogtreecommitdiffstats
path: root/recipes-demo-hmi/homescreen
diff options
context:
space:
mode:
authorNaoto Yamaguchi <i33399_YAMAGUCHI@aisin-aw.co.jp>2016-12-13 21:24:19 +0900
committerNaoto Yamaguchi <i33399_YAMAGUCHI@aisin-aw.co.jp>2016-12-13 22:54:49 +0900
commitac5d5ad0d25b1c511e466415b76feacfd71c5990 (patch)
treeb775bbc18d416156aed50c3227dbbb89ef8e7920 /recipes-demo-hmi/homescreen
parent0a4ff3b6ceb18ca784e6a7a96bdada75602c90d4 (diff)
Provisional fix of libhomescreen's pkgconfig
Since pkgconfig has been disabled, it is not possible to get the configuration of libhomescreen. This patch will make provisional fixes for off-tree build. Change-Id: Ifd8e5818602ab1c4bca4440e1f20b3de46ab5157 Signed-off-by: Naoto Yamaguchi <i33399_YAMAGUCHI@aisin-aw.co.jp>
Diffstat (limited to 'recipes-demo-hmi/homescreen')
-rw-r--r--recipes-demo-hmi/homescreen/homescreen/homescreen.pc.in14
-rw-r--r--recipes-demo-hmi/homescreen/homescreen_git.bb10
2 files changed, 21 insertions, 3 deletions
diff --git a/recipes-demo-hmi/homescreen/homescreen/homescreen.pc.in b/recipes-demo-hmi/homescreen/homescreen/homescreen.pc.in
new file mode 100644
index 00000000..1a70c9ac
--- /dev/null
+++ b/recipes-demo-hmi/homescreen/homescreen/homescreen.pc.in
@@ -0,0 +1,14 @@
+prefix=OEPREFIX
+exec_prefix=OEPREFIX
+libdir=OELIBDIR
+includedir=OEINCDIR
+
+
+Name: libhomescreen
+Description: A generic interface for the HomeScreen app
+Version: 1.0.0
+Libs: -L${libdir} -lhomescreen
+Libs.private: -lgio-2.0 -lgobject-2.0 -lglib-2.0
+Cflags:
+Requires: glib-2.0 gio-unix-2.0
+
diff --git a/recipes-demo-hmi/homescreen/homescreen_git.bb b/recipes-demo-hmi/homescreen/homescreen_git.bb
index 7bef3a28..e03b14d3 100644
--- a/recipes-demo-hmi/homescreen/homescreen_git.bb
+++ b/recipes-demo-hmi/homescreen/homescreen_git.bb
@@ -24,7 +24,8 @@ SRCREV = "${AUTOREV}"
# PV needs to be modified with SRCPV to work AUTOREV correctly
PV = "0.0+git${SRCPV}"
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/p/staging/HomeScreen.git;protocol=http"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/p/staging/HomeScreen.git;protocol=http \
+ file://homescreen.pc.in "
PATH_prepend = "${STAGING_DIR_NATIVE}${OE_QMAKE_PATH_QT_BINS}:"
@@ -47,8 +48,11 @@ do_install() {
# error at build time:
# ERROR: homescreen-git-r0 do_populate_sysroot: QA Issue: homescreen.pc failed sanity test (tmpdir) in path /xdt/build/tmp/work/cortexa15hf-neon-agl-linux-gnueabi/homescreen/git-r0/sysroot-destdir/usr/lib/pkgconfig [pkgconfig]
#
-# install -d ${D}${libdir}/pkgconfig
-# install -m 0644 ${B}/libhomescreen/pkgconfig/homescreen.pc ${D}${libdir}/pkgconfig/
+ install -d ${D}${libdir}/pkgconfig
+ install -m 0644 ${WORKDIR}/homescreen.pc.in ${D}${libdir}/pkgconfig/homescreen.pc
+ sed -i s:OEPREFIX:${prefix}:g ${D}${libdir}/pkgconfig/homescreen.pc
+ sed -i s:OELIBDIR:${libdir}:g ${D}${libdir}/pkgconfig/homescreen.pc
+ sed -i s:OEINCDIR:${includedir}:g ${D}${libdir}/pkgconfig/homescreen.pc
install -d ${D}${includedir}
install -m 0644 ${S}/libhomescreen/include/libhomescreen.hpp ${D}${includedir}/