summaryrefslogtreecommitdiffstats
path: root/recipes-demo-hmi/launcher
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2019-05-23 14:11:07 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2019-05-31 20:41:30 +0000
commit42592b699c78f96525517386e32031b199271043 (patch)
treee6de4b1cf90dc58dd640b3ff978e5dfdef788d13 /recipes-demo-hmi/launcher
parent7b95189a63ff8aa80943ccfa36a2759d9940f0d4 (diff)
Move launcher into meta-agl-demo from meta-agl-devel
Part of the layer cleanup. v2: Fix - moved libhomescreen to meta-agl v3: packagegroup-hmi-framework is too broad and only applies to -demo atm, move here v4: agl-service-homescreen should go to profile-graphical Bug-AGL: SPEC-2450 Change-Id: I00f1fda64af1f9d78b82902438c26c7f9579ae53 Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'recipes-demo-hmi/launcher')
-rw-r--r--recipes-demo-hmi/launcher/launcher_git.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes-demo-hmi/launcher/launcher_git.bb b/recipes-demo-hmi/launcher/launcher_git.bb
new file mode 100644
index 00000000..8c3f72f6
--- /dev/null
+++ b/recipes-demo-hmi/launcher/launcher_git.bb
@@ -0,0 +1,25 @@
+SUMMARY = "AGL Launcher Application"
+DESCRIPTION = "AGL Launcher Application build with recipe method"
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/apps/launcher"
+SECTION = "apps"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+DEPENDS = "\
+ qtbase \
+ qtdeclarative \
+ qtquickcontrols2 \
+ qtwebsockets \
+ qlibwindowmanager \
+ qlibhomescreen \
+"
+
+inherit qmake5 systemd pkgconfig aglwgt
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/launcher;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "${AGL_APP_REVISION}"
+
+PV = "1.0+git${SRCPV}"
+S = "${WORKDIR}/git/"
+
+PATH_prepend = "${STAGING_DIR_NATIVE}${OE_QMAKE_PATH_QT_BINS}:"