summaryrefslogtreecommitdiffstats
path: root/recipes-demo-hmi/mediaplayer
diff options
context:
space:
mode:
authorTadao Tanikawa <tanikawa.tadao@jp.panasonic.com>2016-12-18 21:58:26 +0900
committerTadao Tanikawa <tanikawa.tadao@jp.panasonic.com>2016-12-19 13:56:00 +0000
commit49931c57cb1a7f7d2c74fb7e2ad1591acf465b48 (patch)
tree9a6817899ced8272a5d5bf04c0f1f05a59026454 /recipes-demo-hmi/mediaplayer
parentc85d8a963aab816b05db9ee6230dc8da8c9b0569 (diff)
Add recipe of AGL Demo HMI (Media Player)
This recipe is to deliver AGL Demo Platform for CES2017 AGL Showcase by bitbake integration. To use hmi of Media Player, it should be installed on the target board at least once afer booting. The package of application, mediaplayer.wgt would be installed in /usr/AGL/apps on the target board. To install it, follow these steps from the target console or remote shell. # cd /usr/AGL/apps # afm-util install mediaplayer.wgt Change-Id: I30e69e0027c10a654f657fea250b8f76033f5a52 Signed-off-by: Tadao Tanikawa <tanikawa.tadao@jp.panasonic.com>
Diffstat (limited to 'recipes-demo-hmi/mediaplayer')
-rw-r--r--recipes-demo-hmi/mediaplayer/mediaplayer_git.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/recipes-demo-hmi/mediaplayer/mediaplayer_git.bb b/recipes-demo-hmi/mediaplayer/mediaplayer_git.bb
new file mode 100644
index 00000000..c551e693
--- /dev/null
+++ b/recipes-demo-hmi/mediaplayer/mediaplayer_git.bb
@@ -0,0 +1,32 @@
+SUMMARY = "Media Player for CES2017 AGL Demonstration"
+DESCRIPTION = "AGL HMI Application for demonstrating Media Player on AGL Distribution"
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/mediaplayer"
+LICENSE = "Apache-2.0"
+SECTION = "apps"
+
+PV = "1.0+git${SRCPV}"
+S = "${WORKDIR}/git"
+
+inherit qmake5
+
+# 'wgtpkg-pack' in af-main-native is required.
+DEPENDS = "af-main-native"
+
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/mediaplayer;protocol=http"
+SRCREV = "${AUTOREV}"
+
+RDEPENDS_${PN} += " \
+ qtmultimedia-qmlplugins \
+ qtquickcontrols2-qmlplugins \
+ "
+
+do_install() {
+ install -d ${D}/usr/AGL/apps
+ install -m 0644 ${B}/package/${PN}.wgt ${D}/usr/AGL/apps/
+}
+
+FILES_${PN} += "/usr/AGL/apps/ \
+ /usr/AGL/apps/${PN} \
+ "